Can't change passwd and mount-0 rw,remount/ didn't work either !!

Asked by Paul Paquin on 2013-02-27

I am running Ubuntu 12.1 64 bit. Dual boot for Ubuntu or Win 7. In settings I changed password to "none" not knowing the OS needs to have a password. I tried changing it in settings, will not allow . I tried reboot holding down shift key , going to recovery mode and changing password in root, it said,"authentication token manipulation error, password unchanged. I read some more, and tried in terminal "touch /forcefsck", it said ca not touch force forcefsck: permission denied. I booted into recovery mode chose the option fsck, it said, "/dev/loop0: super block last mount time is in the future. (by less than a day, probably due to the hardware clock being incorrectly set) FIXED

So now how do I put a password back on the OS?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-27
Last reply:
2013-02-27
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi,

read carefully the instructions on this link
http://www.psychocats.net/ubuntu/resetpassword

Thank you

Paul Paquin (thewarrior43) said : #2

If you read through my post you'll see I tries that gave the results and tried other avenues by reading other posts as well.

Warren Hill (warren-hill) said : #3

Take a look here
http://askubuntu.com/questions/91188/authentication-token-manipulation-error

It sounds like the problem may be related to having had the clock set wrong in which case the second answer may solve it for you.

Manfred Hampl (m-hampl) said : #4

Have you entered the "mount -o rw,remount /" command before trying to change the password or doing "touch /forcefsck"?

Paul Paquin (thewarrior43) said : #5

Just to let you know, and I don't know why because all I've done is install a couple sudo updates and sudo upgrades, when I go to choose recovery mode I get a choice of three different images gnu 3.5.0-25, -23 and -17. Don't get that one anyway, OS said there were updates available again just now, so I installed them. Went to recovery mode, in root interface typed mount -o rw/remount then tried the passwd change and got same result, password unchanged. Tthen I tried mount mount -o rw/remount command again then put in the touch /forcefsck command and it said "read only file system"

should I make a live cd to replace damaged files?

Paul Paquin (thewarrior43) said : #6

ok I read the link you gave again and found that there was a space between remount and the slash /. I tried this and it reset the password successfuly. It still doesn't require password at login but I installed libre fonts so authentication is working. Should I go back and change settings to put password at login?

N1ck 7h0m4d4k15 (nicktux) said : #7

Hi,

Probably you've made a mistake in the command.

All the commands in Unix/Linux are case sensitive and all the symbols are matters.
Try again the command carefully.

mount -o rw,remount /

Be careful with dash, commas , spaces .. etc..
If the command executing correctly the results must be nothing. Only a new (blank) line.

I've told you that in the first answer also .. "read carefully the instructions".

Thank you.

N1ck 7h0m4d4k15 (nicktux) said : #8

Yes , you can go to settings and change the option for automatic login to OFF.
Open User Accounts and you will see it.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Paul Paquin for more information if necessary.

To post a message you must log in.