12.10 Forgotten Password

Asked by Chris Brock on 2012-12-14

Hello,

I am very new to Ubuntu, so please bear with me. I gave my Lenovo Y510 to my father-in-law to repair when a windows driver magically came up missing. He tried for a little while and said "Screw this, we are going to make this an Ubuntu system." He installed it for me while I was away on business. He setup the operating system(Ubuntu 12.10) and the password. He made the password his daughters name but accidentally made a typo. Therefore I searched around on the forum and found many problems similar to mine. However, all the solutions, I try, I get different results than the solutions found on the forum.

So here is what I tried:

First, I tried the unofficial solution, which can be found here: http://www.psychocats.net/ubuntu/resetpassword

I figured out how to get in to the root shell.

I type the first command verbatum which is this: mount -o rw,remount/

after I press enter, I get something that explains that I can only remount a file system (it gives a very long explaination of this and other things as well as a list of options, but the part I mentioned is all I remember).

So that kind of stumped me, I tried different combinations of spacing and etc. thinking I have made a typo in the command and as far as I can tell I have not.

Then I tried the official documentation method which can be found here:
https://help.ubuntu.com/12.10/ubuntu-help/user-forgottenpassword.html#live-cd

I have a little bit more luck with this method. I get farther into the steps. However, when I enter the new password it says "Authentication Token Manipulation Error" then another line below that says "password unchanged". I know I am not spelling the passwords differently because I have done that and before I get the token manipulation error is tells me the password does not match.

I did not try the other two solutions on the official documentation, because I am new to Ubuntu and am not sure if I am advanced enough to try them.

Does anybody have any ideas as to what I should do next? Thank you for all of your help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-14
Last reply:
2012-12-15
N1ck 7h0m4d4k15 (nicktux) said : #1

It seems that you have tried the 2 most popular methods of reseting password and as you stated "newbie user" I cannot suggest anything else except to try again the method from psychocat's site.

Be careful , be very careful when write the commands. As you (probably) already understood , Linux is very sensitive in writing. Caps , commas , spaces , dashes , everything matters. So proofread twice before hit Enter.

The command as you quoted here is wrong . Look again , it wants a space between remount and /

mount -o rw,remount /

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Chris Brock for more information if necessary.

To post a message you must log in.