I can no longer authenticate myself as administrator

Asked by schreinemachers on 2012-09-17

Dear helper
Since I have turned on my automatic Ubuntu login I can no longer authenticate myself as administrator . Using the 12.04 ubuntu.
It is also not possible to reverse this option. I can therefore nolonger unlock the keyring.
The recovery >boot. > select new unix password gives an error.
Have also tried to empty the keyring info without success.
Can someone help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
Warren Hill
Solved:
2012-09-17
Last query:
2012-09-17
Last reply:
2012-09-17

When you are in root recovery and run:

passwd foo

(replace foo with your username). What is output?

Thanks

Thomas Krüger (thkrueger) said : #3

Is it possible you took yourself out of the administators group accidently?
Can you please open the Terminal, run the following command and post the output:
id
(yes, it's that short)

schreinemachers (ws-starminx) said : #4

Thanks for the reply.
output is: "Authentication token manipulation error
Password unchanged"

Willem

On 09/17/2012 05:26 PM, actionparsnip wrote:
> Your question #208816 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208816
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> When you are in root recovery and run:
>
> passwd foo
>
> (replace foo with your username). What is output?
>
> Thanks
>

schreinemachers (ws-starminx) said : #5

On 09/17/2012 05:56 PM, Thomas Krüger wrote:
> Your question #208816 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208816
>
> Thomas Krüger requested more information:
> Is it possible you took yourself out of the administators group accidently?
> Can you please open the Terminal, run the following command and post the output:
> id
> (yes, it's that short)
>
Thanks for your reply, this is the output :
> willem@willem-Vostro1710:~$ id
> uid=1000(willem) gid=1000(willem)
> groups=1000(willem),4(adm),20(dialout),24(cdrom),46(plugdev),109(nopasswdlogin),116(lpadmin),118(admin),124(sambashare)
> willem@willem-Vostro1710:~$

Best Warren Hill (warren-hill) said : #6

When I run the 'id' command I get this

warren@dell:~$ id
uid=1000(warren) gid=1000(warren) groups=1000(warren),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),109(lpadmin),124(sambashare),125(wireshark)

It appears that for for some reason you have stopped being a member of the sudo group

Press shift during start-up so you get into recovery mode or if that doesn't work use a live CD then enter the following command

usermod -G -a sudo willem

schreinemachers (ws-starminx) said : #7

Warren, Ran in the terminal "passwd willem", was asked to enter new password, confirmed and was then informed that the new password had been changed successfully . The success is confirmed by getting access to and able to change the user account settings.
Thanks for the indirect help.
Willem