Removed login password, after initially using one. Now it wants password to do any administration stuff, but there isn't one anymore

Asked by James Hammit on 2012-06-12

After installing Ubuntu, I decided that I didn't need a log in password, so I removed it.

But now whenever i need to install a program or anything else that requires admin permission, it says that I need authentication password, but there isn't one anymore.

So I tried the old password and it didn't work, nor did the key ring password either.

Those are the only two passwords that have been used on this system...ever.

Nothing seems to work.

I know the passwords were correct.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-12
Last reply:
2012-10-23
wojox (wojox) said : #1

How did you remove the password?

James Hammit (jimh-nv) said : #2

under login options in user accounts. I removed the password after being prompted to give the password in order to remove it

James Hammit (jimh-nv) said : #3

The current settings for the login options are- Password: none Automatic Login: on

You will need a password to perform admin tasks. I suggest you reboot to root recovery mode and set your password using:

passwd foo

replace foo with your username. Eg:

passwd andy

You can then run:

reboot

and be ok.

Mike Rozel (mrozel) said : #5

I have tried what you suggested, but get a menu of extensions when I enter passwd foo. At no time am I asked to enter a new password.

Can you help with this problem?

Provide an answer of your own, or ask James Hammit for more information if necessary.

To post a message you must log in.