Can not login; no password for login

Asked by Andrew on 2012-06-02

I have been using ubuntu-12.04 mounted on an USB drive so I can access my HP laptop (Vista) to recover files and troubleshoot a start-up issue. My wife wanted to use it to get into Facebook and play her games so I created an Admin account for myself and a standard one for my wife.

At no time did I enter in a password or was prompted to do so. The only button on the creation window was Automatic Password something or another, which I though meant to require a password. I wanted a simple access and didn't want any passwords at this time so I let the buttons remain at NO. I now realize that that button should have been a YES to override any password requests.

Anyway, I don't remember ever entering in any passwords for the USB or anywhere else. Before I created the accounts, Ubuntu simply started. I now cannot get access to the computer. Both my wife's and my user names come up for login, but I have no passwords to enter.

I attempted some of the workarounds I found in here but am weary about attempting them as I am not savvy enough and besides, I don't even think I had any access to this GRUB menu or root menu etc. I tried holding SHIFT or ESC while booting and nothing seemed to come up, at least nothing that I would want to screw with.

Can anyone help me here?
Perhaps I should remount the Ubuntu fresh on the USB and start over?

Question information

English Edit question
Ubuntu shadow Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Jeet (gour-jitendrasingh) said : #1

I think here covered all techniques Please read this


Always set passwords, they are there for a reason.

Andrew (buskieboy) said : #3

Thanks folks. I just used the KISS method and reinstalled a fresh version on my UBS
and it is now working.