Ubuntu

password invalid following installation

Asked by Brian on 2012-02-02

I've installed 11.10 twice. First the 64 bit, then the 32 bit version. In both cases the password I enter during the installation process will not work once installation is complete. I'm installing a dual boot with Windows XP. Both times I have selected to load all updates and 3rd party software. On the second install I selected to boot up without prompting for a login but I am still to limited in setting up the system.

In both instances I've followed the process described in http://www.psychocats.net/ubuntu/resetpassword
In both instances I receive the following error "authentication token manipulation error"

I can't find anyone else having this issue but also find it hard to believe it could be unique to my hardware (dell desktop). All of the applications I've tried seem to work.

Anyone have any ideas or can point me to a different procedure??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
Brian
Solved:
2012-02-03
Last query:
2012-02-03
Last reply:
2012-02-03
Brian (geekn4money) said : #2

this didn't work as sudo still needs a password to remove likewise. My installed password is invalid therefore I don't have much access so most system files are read only

mycae (mycae) said : #3

The brute force way to alter your password is to use a liveCD to modify /etc/shadow with a known hash.

Boot to the liveCD, then set the password to some known value. Looki in /etc/shadow on the liveCd root mount, then use that hash to replace the hash in contents of your normal "/" (which presumably is in /media/someidvalue/etc/shadow . You can do this with a text editor

Brian (geekn4money) said : #4

I can't create a user when running the live CD so I can't create a needed shadow entry -- nor do I even have read access to my installed version of shadow @ /media/51b36ad9-7b41-45d7-b29f-dea4ad30bcc4/etc so forget editing it.

Am I missing something in your procedure?

If you think I should be able to perform these operations then maybe that's a clue.

 The only thing I can think of as a root cause is that I forgot and left a weather station connected to a serial port during installation. Has anybody encountered a serial devices screwing with passwords before? I have a vague memory from years ago otherwise I wouldn't think it was worth mentioning.

What is the output of:

lsb_release -a; uname -a

Thanks

Brian (geekn4money) said : #6

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux D3V0KFK1 3.0.0-15-generic-pae #26-Ubuntu SMP Fri Jan 20 17:07:31 UTC 2012 i686 i686 i386 GNU/Linux

Brian (geekn4money) said : #7

I've re-installed w/o the weather station plugged into my serial port. Passwords now work fine. I used the exact same password as I had in the other two installations.

Before the install process would tell me these were strong passwords. With the serial port input eliminated, I noticed that my password was only rated fair.

Possibly there's something deep in the kernel that assumes the serial port is the console -- at least during install??

Andrew, Mycae

response to lsb_release same as above.

Thanks for your suggestions, if nothing else I have a few new tools for future troubleshooting.

Brian (geekn4money) said : #8

Should this be a bug report??

 I will make sure it's reproducible if support thinks it is of consequence. The easy fix would be to update the installation docs to tell users to make sure there is nothing transmitting to a serial port during installation (unless of course you are using a terminal device for some reason instead of your PC's standard I/O.