Admin password?

Asked by rami on 2012-01-02

Hello folks,

I have installed a brand new Ubuntu 11.10. I was playing with the "User Accounts" settings. I have added a password to my administrator account, and it worked fine. Then I have chosen to put the password to "None".

I am not able to unluck the profile, and even when I click on "None" for Password, I am not able to add a new password, since the "Change" button is grayed out.

I have left the "Current password" empty, since I don't have any password any more.

What to do, so I can add a password to my administrator account?

P.s. I have read on the net, that I have to click on ESC when I boot, etc.. But nothing happens when I click on ESC.

I hope you can help.

Best regards
Rami

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
rami
Solved:
2012-01-03
Last query:
2012-01-03
Last reply:
2012-01-03
Chris (fabricator4) said : #1

Hitting <Esc> will only bypass the graphical splash screen and put the system back in the console so you can monitor the boot process.

Are you still able to login automatically with your admin login (the one you defined when you first installed Ubuntu? If so, do this and on open a terminal windows and type:

passwd

It will ask for your current password, then will ask you twice for your new password. As far as I'm aware it's not actually possible (or safe) to have an admin account with no password, but see how you go.

Chris

www.psychocats.net/ubuntu/resetpassword

delance (olivier-delance) said : #3

https://help.ubuntu.com/community/LostPassword

@Chris and @Andrew
Now, with 11.10 psychocat is out of date, as recovery option at boot changed

rami (rami-elkhatab) said : #4

Hello folks,

I opened the terminal and I have typed:

passwd <MY NAME>

Then I was asked to type a password and confirm it. It worked.

But my Ubuntu is not asking me to write any passwords when I enter it. I just get a login button, which is not that save. So I'd like to have the Ubuntu to ask me for my credentials before entering the OS. How to do so?

Best wishes
Rami

delance (olivier-delance) said : #5

With Unity,
Top right icon->System->User accounts->Login option: No automatic login

rami (rami-elkhatab) said : #6

Hi again,

Thanks alot. Super... I have tried it. When I use automatic login to ON, I just enter the OS automatically. But If I set it to OFF, I get the "LOGIN" button. It's not asking me for my password.

How to make Ubuntu asking me for my password, everytime I try to enter it?

Best regards
Rami

delance (olivier-delance) said : #7

Could you describe the screen or paste a picture in a paste/bin Web site.
Did you set a new password (not a null one) ?
It asks me my password each time I power on my PC.

rami (rami-elkhatab) said : #8

Hi Olivier,

I have created a user and gave him administrator privileges. It worked just fine with the password login field. So I have deleted my first administrator profile and kept the second one. It's a brand new Ubuntu installation, so it wasn't that critical.

Thanks everyone.

P.s. By the way, I'm a hardcore Windows user. I'm just testing Ubuntu, and I'm very impressed so far :-)

Best regards
Rami