Ubuntu 11.04 login and password required on upgrade boot up with no previous login or password for 10.04 and 10.10.

Asked by Chuck on 2011-12-13

I upgraded my Ubuntu 10.04 to 10.10 and then to 11.04 and during the restart after downloading 11.04 it asked me to login and for a password which I don't remember being asked for one or making one on previous versions. I haven't been able to find an answer for the problem and need help or I'll wind up losing all my information that I haven't backed up. I know, I should've done that.
chuck

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
Chuck
Solved:
2011-12-24
Last query:
2011-12-24
Last reply:
2011-12-19

This question was reopened

You will have set one up in the initial install of the OS when you set your username. You can reset your password with this:
http://www.psychocats.net/ubuntu/resetpassword

Chuck (av1611biblepreacher) said : #2

I have tried your answer already. Nothing happens when I hold the shift key down. It still goes to the DOS login/ password screen. when i have tried to put in a password no keystrokes show up nor does the cursor move any. not sure that is normal as usually you see keystrokes show up in the password box when typing.

mycae (mycae) said : #3

Are you holding the left shift key, rather than the right?
https://wiki.ubuntu.com/RecoveryMode

Even if you can't login, you can still recover your data using a liveCD/USB, if you have access to a second computer, or an old ubuntu disk. Simply insert the liveCD, then use the file-browser to navigate to your files (they will be on your hard drive). Once you have them, save them to an external disk, or if you have multiple CD devices, you can burn a CD with your files.

You should certainly be able to use the recovery mode to reset the password however. I do *not* recommend the liveCD data recovery procedure in this situation, as it is the more complicated route.

Chuck (av1611biblepreacher) said : #4

i was able to get to the recovery screen. i followed the instructions on the link you gave me and it worked exactly like the page said using the escape button to get in and not the shift key. it worked up to the point that there wasn't a password link in the box to choose from so i followed the suggestion/ instruction to choose; drop to root shell prompt abd it gives me root@biblepreacher: ~#. i have not idea what that is or what to do with it.

Read the rest of the page....

It's all there. Why did you stop??

Chuck (av1611biblepreacher) said : #6

Because, the only thing after that last line is a remote/ recovery link. There isn't anything else on the link that I was given. Otherwise I would have continued on till the problem was solved.

So you never saw:

Once you're at the root shell prompt, if you have forgotten your username as well, type

ls /home
That's a lowercase L, by the way, not a capital i, in ls. You should then see a list of the users on your Ubuntu installation. In this case, I'm going to reset Susan Brownmiller's password.
To reset the password, type

passwd username
where username is the username you want to reset. In this case, I want to reset Susan's password, so I type
passwd susan
You'll then be prompted for a new password. When you type the password you will get no visual response acknowledging your typing. Your password is still being accepted. Just type the password and hit Enter when you're done. You'll be prompted to retype the password. Do so and hit Enter again.

Now the password should be reset. Type

exit
to return to the recovery menu.

Chuck (av1611biblepreacher) said : #8

Exactly. I don't see that on the link https://wiki.ubuntu.com/RecoveryMode up above. I'll try that and let you know.

Chuck (av1611biblepreacher) said : #9

Okay, I was able to set the password but when trying to reset the username it tells me that there isn't a username set. Evidently it won't let me in without the username. I thought my user name was biblepreacher. when i sign in to the main window, I sign in with my first name. So, how in the world do I give it a username?

Chuck (av1611biblepreacher) said : #10

When I put in passwd username to change the username it says, passwd: user 'username' does not exist.

Think about it......

You use YOUR USERNAME that you log in with.....

Chuck (av1611biblepreacher) said : #12

I did think about it and I have tried every word I would usually use for logins and passwords and nothing works. I said before if I have a user name I didn't know what it was so the logical conclusion would be if the system requires a username and/ or a password and I don't have one or I forgot somewhere down the line then I would need to be able to set one or reset one. Don't you think? I hope I'm making since. It's difficult sometimes to get ones point across using this medium.

So, I'll try to be as clear as I can. I have never ever logged in in DOS before. I stated that before. I have logged in in the Ubuntu screen for my own particular desktop using a password and that is all not a login word/ username, whatever you want to call it. I have upgraded from Ubuntu 8.10 (the version I started out with originally), and have never had to log in in DOS during the start up process when it is loading the system for each additional upgrade. Not that I'm not appreciative of you guys help and I am but it would appear that you all have not seen this problem before or there is a misunderstanding somewhere. I'm not giving up yet but I wonder if it might be better if I burned my filesto a cd and reloaded the Ubuntu fresh. Only, I hate to lose all the bookmarks I have in Firefox.

If your data is important you should have a backup.

It's not DOS you are typing in, it's a bash shell, bash is a million times more powerful than DOS.

All you need is the passwd command and you can set your password of your username, my command on my system would be:

passwd andy

You can see your username by running:

ls /home

and you will see the usernames on the system.

Chuck (av1611biblepreacher) said : #14

Well, praise the Lord! It worked. The reason the username wasn't coming up was because I was typing it in; ls/ home instead of ls /home. lol. Needless to say, my username came up.

I reentered the password again. I found that I could change the password whether I typed in:

passwd chuck or passwd.

It didn't matter which one I typed in. So I typed in the same password I originally put in, exited, typed in the login username, the password and it loaded up. It then prompted me if I wanted to to upgrade to Oneiric and I did. Hopefully that one will be as user friendly like the 11.04 was supposed to as I'm not so technical when it comes to computers.

Anyway, I want to thank you for all your help. It is very much appreciated. I'm sorry for dragging this out. :). Have a wonderful day. Psalm 24:1

chuck

Chuck (av1611biblepreacher) said : #15

Thanks actionparsnip, that solved my question.

Chuck (av1611biblepreacher) said : #16

Now, I have a question and I'm not sure whether to put this here or post it somewhere else. I did the restart as it asked when upgrading to 11.10 and now it's stuck at:

chuck@biblepreacher:~$.

By the way, thanks for correcting my on the bash shell and DOS.

So you upgraded then get no desktop?

Chuck (av1611biblepreacher) said : #18

Yes.

If you can, run:

sudo apt-get --reinstall install lightdm

Then reboot, seeif it helps

Chuck (av1611biblepreacher) said : #20

I typed that in and hit enter and this is what comes up typing in the command two different ways or moer:

command not found and/ or

E: Invalid operation reinstall.

I also typed that in and rebooted the computer just in case that's what really meant and nothing different happened.

Are you putting the spaces in? Check the syntax and spacing you are using. You must be accurate

Chuck (av1611biblepreacher) said : #22

Okay, I tried what you put in here several different ways and they didn't work so I put in this:

sudo aptitude reinstall lightdm.

Apparently it worked since 'Light DM Display Manager' [failed] doesn't show up anymore.

However it still goes back to:

 chuck@biblepreacher:~$.

Now from the top it says:

Boot from (hd0,0) ext3 5d69ac40-6caa-476d-bc93-a5d8c462af13
Starting up...
[ 10.217845] SP5100 TCO timer: mmio address 0xfec000f0 already in use
* Stopping save kernel messages [OK]

Ubuntu 11.10 biblepreacher tty1

biblepreacher login:
Ubuntu 11.10 bibpreacher tty1

biblepreacher login:
password:
last login: Mon Dec 19 20:38:12 CST 2011 on tty1
Welcome to Ububntu 11.10 (GNU/Linux 3.0.0-14-generic-pae i686)

* Documentation: https://help.ubuntu.com/

chuck@biblepreacher:~$

Chuck (av1611biblepreacher) said : #23

started the computer up today and this is what it says now:

Boot from (hd0,0) ext3 5d69ac40-6caa-476d-bc93-a5d8c462af13
Starting up...
[ 18.138310] SP5100 TCO timer: mmio address 0xfec000f0 already in use
[18.199787] k10temp 0000:00:18.3: unreliable CPU thermal sensor; monitoring disabled [OK]

* Starting Timidity++ ALSA midi emulation... [OK]

Ubuntu 11.10 biblepreacher tty1

biblepreacher login:
password:
last login: Mon Dec 19 21:03:02 CST 2011 on tty1
Welcome to Ububntu 11.10 (GNU/Linux 3.0.0-14-generic-pae i686)

* Documentation: https://help.ubuntu.com/

chuck@biblepreacher:~$

Chuck (av1611biblepreacher) said : #24

I will close this out since the main problem is solved, a new one has surfaced and no one is answering my new question now.