Since upgrading cannot sign on as sudo due to authentification failure

Asked by John Wilson on 2011-11-04

Since upgrading to 11.10 I cannot sign on as su
Get an authentification failure message
John

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-04
Last reply:
2011-11-06
John Wilson (jwilsondmartin) said : #2

Thank you for your prompt help.
When I tried resetting my password I got the following error message:
passwd: Authentication token manipulation error
passwd: password unchanged

I tried several times to reset my password taking care my typing is accurate but still the same result

http://www.ideaexcursion.com/2009/09/11/fixing-authentication-token-manipulation-error-when-changing-passwords-with-passwd/

Shows

sudo apt-get remove likewise-open

You can boot to root recovery mode and install the package there.

John Wilson (jwilsondmartin) said : #4

john@john-775Dual-880Pro:~$ sudo apt-get remove likewise-open
[sudo] password for john:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package likewise-open is not installed, so not removed

It would appear that I don't have likewise-open installed
Should I and how would I configure it?

likewise-open can sometimes *cause* this problem, but not having it won't cause the problem. You don't have likewise-open. You shouldn't install it. Instead, something else is causing the problem.

We may be able to sidestep the problem altogether.

First, try https://help.ubuntu.com/community/LostPassword#The_Other_Way. (If you find those directions confusing, then after it says "Your system will boot up to a passwordless root shell," you can start following the instructions at http://www.psychocats.net/ubuntu/resetpassword.)

If that doesn't work, then in your Ubuntu system, open a Terminal window (Applications > Accessories > Terminal) and enter this command exactly (you can copy and paste it)

mount | grep ' on / '

and press enter to run that command. You should see something like:

/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)

The part you're interested is the device name before "on" (in this example, it's /dev/sda1). Remember that, or write it down.

Now boot the computer from an Ubuntu Desktop Install CD (you can burn the .iso image to a CD or DVD, or write it to a USB flash drive and boot from that) and select Try Ubuntu. When the desktop comes up, run the Terminal and, in the Terminal window, run:

sudo mount /dev/sda1 /mnt

If the device name was different from /dev/sda1, put what you saw instead. Then run the commands:

sudo chroot /mnt
passwd USERNAME

Replace USERNAME with your actual username. This will enable you to type in a new password. Enter your new password twice, as it requests. It's OK that no placeholders characters (like *) appear while you're entering your password.

Then run these three commands:

exit
sudo umount /mnt
exit

The last of those commands quits the Terminal window. Reboot the system by clicking the power icon on the upper-right corner of the screen and clicking Restart. Make sure to remove the CD before the system boots up again, so that you can get into your Ubuntu system on the hard disk. Now that you've reset your password, you should be able to authenticate when necessary.

Can you help with this problem?

Provide an answer of your own, or ask John Wilson for more information if necessary.

To post a message you must log in.