I installed ubuntu11.10 now I cannot authenticate anything it will not accept my password

Asked by John Bryant on 2011-10-22

Ever since I installed the new version of Ubuntu I cannot install or remove anything the program will not accept my password. How do I reinsert my password ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
John Bryant
Solved:
2011-12-19
Last query:
2011-12-19
Last reply:
2011-11-05
John Bryant (johnvelda) said : #2

I tried to follow the directions but where it said to type " ls/home" I received the response
bash: ls/home: no such file or directory
{my computers name is "dad"}
so I typed in "passwd dad" it allowed me to type the new password then I retyped the new password hit enter I then received the message "authentication token manipulation error" passwd: password unchanged.
Please help
John

"bash: ls/home: no such file or directory"

You left out the space between ls and /home.

John Bryant (johnvelda) said : #4

I put the space in it went through to "enter new UNIX password" so I did, it then asked me to "re enter new UNIX password" so I did, then the following message come up " passwd: authentication token manipulation error, passwd: password unchanged, root@dad-desktop:~# " I tried several passwords but the same answer came up.

First, try https://help.ubuntu.com/community/LostPassword#The_Other_Way. (If you find those directions confusing, then after it says "Your system will boot up to a passwordless root shell," you can start following the instructions at http://www.psychocats.net/ubuntu/resetpassword.)

If that doesn't work, then in your Ubuntu system, open a Terminal window (Applications > Accessories > Terminal) and enter this command exactly (you can copy and paste it)

mount | grep ' on / '

and press enter to run that command. You should see something like:

/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)

The part you're interested is the device name before "on" (in this example, it's /dev/sda1). Remember that, or write it down.

Now boot the computer from an Ubuntu Desktop Install CD (you can burn the .iso image to a CD or DVD, or write it to a USB flash drive and boot from that) and select Try Ubuntu. When the desktop comes up, run the Terminal and, in the Terminal window, run:

sudo mount /dev/sda1 /mnt

If the device name was different from /dev/sda1, put what you saw instead. Then run the commands:

sudo chroot /mnt
passwd USERNAME

Replace USERNAME with your actual username. This will enable you to type in a new password. Enter your new password twice, as it requests. It's OK that no placeholders characters (like *) appear while you're entering your password.

Then run these three commands:

exit
sudo umount /mnt
exit

The last of those commands quits the Terminal window. Reboot the system by clicking the power icon on the upper-right corner of the screen and clicking Restart. Make sure to remove the CD before the system boots up again, so that you can get into your Ubuntu system on the hard disk. Now that you've reset your password, you should be able to authenticate when necessary.

John Bryant (johnvelda) said : #6

I would like to thank everybody for their help with my password problems.
I could not fix the problem so I took my computer down to a very knowledgeable man in Ubuntu, and he found that when I installed 11:10 it also installed a package called "likewise-open" which locked me out of the program, he went into recovery and deleted the package and now it works. Once again thank all of you.
John