Authentication fails every time my valid password is used

Asked by Bob Burke on 2011-09-08

This is not a networked computer, nor is it a dual platform computer. I only run this desk top computer in Ubuntu. Upon entering my valid pass word when required by the authentication process, a return message says that the password is incorrect.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-09-08
Last query:
2011-09-08
Last reply:
2011-09-08
marcus aurelius (adbiz) said : #1

make sure capslock isn't enabled. if you need to reset your password, google "pyschocat reset password" and follow the instruction in the link to reset the password.

If the above information does not fix the problem (including http://www.psychocats.net/ubuntu/resetpassword), then in the Terminal in your installed Ubuntu system that has the problem, please run this command (paste it into the Terminal and press enter--this avoids typos), then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

lsb_release -a; echo; groups; echo; gconftool-2 -R /apps/gksu

Bob Burke (rbt-burke) said : #3

The "psychocat" suggestion (marcus aurelius) did not work, because once I selected my image and then "Drop to root shell prompt" in the Recovery Menu, I was presented with a password prompt "for maintenance", That of course put me in the same place where my valid password did not work. Here is the paste up from the second suggestion (Eliah Kagan)
bob@bobs-desktop:~$ lsb_release -a; echo; groups; echo; gconftool-2 -R /apps/gksu
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

bob adm lp dialout fax cdrom floppy tape audio dip video plugdev fuse lpadmin netdev admin nopasswdlogin sambashare

 sudo-mode = true
 prompt = false
 force-grab = false
 save-to-keyring = false
 display-no-pass-info = false
 disable-grab = false
 save-keyring = session
bob@bobs-desktop:~$

The output of the commands I gave you indicates that your system is properly configured, so resetting the password should fix your authentication problems--you'll just have to use an alternative method, since the commonly used method Marcus suggested won't work in this case.

First, try https://help.ubuntu.com/community/LostPassword#The_Other_Way. (After it says "Your system will boot up to a passwordless root shell," you can start following the instructions at http://www.psychocats.net/ubuntu/resetpassword.)

If that doesn't work, then in your Ubuntu system, open a Terminal window (Applications > Accessories > Terminal) and enter this command exactly (you can copy and paste it)

mount | grep ' on / '

and press enter to run that command. You should see something like:

/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)

The part you're interested is the device name before "on" (in this example, it's /dev/sda1). Remember that, or write it down.

Now boot the computer from an Ubuntu Desktop Install CD and select Try Ubuntu. When the desktop comes up, run the Terminal and, in the Terminal window, run:

sudo mount /dev/sda1 /mnt

If the device name was different from /dev/sda1, put what you saw instead. Then run the commands:

sudo chroot /mnt
passwd bob

If bob isn't your username, put your username there instead. This will enable you to type in a new password. Enter your new password twice, as it requests. It's OK that no placeholders characters (like *) appear while you're entering your password.

Then run these three commands:

exit
sudo umount /mnt
exit

The last of those commands quits the Terminal window. Reboot the system by clicking the power icon on the upper-right corner of the screen and clicking Restart. Make sure to remove the CD before the system boots up again, so that you can get into your Ubuntu system on the hard disk. Now that you've reset your password, you should be able to authenticate when necessary.

Bob Burke (rbt-burke) said : #5

My problem is solved.
It did require the last alternate, booting from an Ubuntu Desktop CD.
There was not enough clarity using https://help.ubuntu.com/community/LostPassword#The_Other_Way.
steps 3) Select your image and 4) Highlight the line that begins kernel and press 'e' to edit were ambiguous to me. I didn't know if I was to select the regular image or the recovery image. I tried both, but found nothing where I could see a line to highlight that began "kernel" nor ended "ro". More clarity is needed in that approach.