computer requires a masterpassword I did not setup

Asked by rebel_lady_ok on 2011-02-28

Whenever I try to upload the updates available or a new program, it asks for a master password that I did not setup to have. I have not been able to receive any updates or try new programs. Is there a way to reset the master password or simply remove it. I never set up a master password because this computer stays at my home and saw no reason for one. Thank you.

you can reach me at <email address hidden>

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Last query:
2011-02-28
Last reply:
2011-03-01

You set your password when you made your first user.

rebel_lady_ok (rebel-lady-ok) said : #2

when i set my user name i never added a password, i just hit enter.

alvin exline (alexline) said : #3

if you get answer i need it to.

The OS NEEDS a pasword. Having a blank password is a really BAD idea unless you intend to never go on the internet. This is fixable but please set a password next time and you won't have to go through this rigmarole

Reboot the system and hold shift, select recovery mode then select root

Now run:

cd /home
ls

(ls is LS in lowercase)

You can now see your username. If you now run:
passwd foo

(replace foo with your username)

You can now set a password. then run:
reboot

to reboot the system, let the system boot and log in with your password. You will now have zero issues.

rebel_lady_ok (rebel-lady-ok) said : #5

thank you, i'm signing off and will let you know if this worked. thank you.

rebel_lady_ok (rebel-lady-ok) said : #6

actionparsnip, i did what you said. i rebooted and held shift but the only thing that happened was a message of sorts that read "mbr zfa:_" the underscore was blinkling but it wouldn't allow me to type anything in.i'm pretty much a dummy with computers and this is my first foray with Ubuntu but rebooting and holding shift is pretty straightforward so i still don't have an answer.

alvin exline (alexline) said : #7

al says thank you and signing off also.

Rebel, as the install is new I suggest you reinstall and set a password. Blank passwords for ANYTHING is a really bad idea. The system has them for a reason....

What name did you give the system?

First of all, you might be able to simply press enter when asked for your password. After all, your password is blank, and pressing enter when asked for it submits the blank password. If that works, then you should still set a password for yourself (but you can do that in System > Administration > Users and Groups).

If that doesn't work, then since you're not able to access the boot menu and select Recovery Mode by holding down the Shift key when starting up, try the Escape key instead. Please also take a look at http://www.psychocats.net/ubuntu/resetpassword, which provides more detailed information (including screenshots, and even a video) explaining and assisting with this technique.

If that doesn't work either, then since you seem to be unable to boot into recovery mode, you can reset your password with a different, slightly more time-consuming, but not particularly difficult alternate technique. To reduce confusion, I'll post instructions for that technique separately.

** Alternate Technique For Resetting Password **

Open a Terminal window (Applications > Accessories > Terminal) and enter this command exactly (you can copy and paste it)

mount | grep ' on / '

and press enter to run that command. You should see something like:

/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)

The part you're interested is the device name before "on" (in this example, it's /dev/sda1). Remember that, or write it down.

You'll also need to know your username. If you don't know your username, run the command:

whoami

That outputs your username. Remember (or write down) that too.

Now boot the computer from an Ubuntu Desktop Install CD and select Try Ubuntu. When the desktop comes up, run the Terminal and, in the Terminal window, run:

sudo mount /dev/sda1 /mnt

If the device name was different from /dev/sda1, put what you saw instead. Then run the commands:

sudo chroot /mnt
passwd <username>

Replace <username> with your actual username (and don't include the < and > characters). This will enable you to type in a new password. Enter your new password twice, as it requests. It's OK that no placeholders characters (like *) appear while you're entering your password.

Then run these three commands:

exit
sudo umount /mnt
exit

The last of those commands quits the Terminal window. Reboot the system by clicking the power icon on the upper-right corner of the screen and clicking Restart. Make sure to remove the CD before the system boots up again, so that you can get into your Ubuntu system on the hard disk. Now that you've reset your password, you should be able to authenticate when necessary.

(Or you can just redo the installation, as actionparsnip suggests.)

Can you help with this problem?

Provide an answer of your own, or ask rebel_lady_ok for more information if necessary.

To post a message you must log in.