Do not know admin password

Asked by Kel Fowler on 2011-02-15

Hello

I installed from a private CD Ubuntu 7.1 Dell OEM. It run normally but I am unable to update it because it asks for an admin password. But I never set this password. How do I find out what it is?

Please I am very new to Linux, so please speak very simple English.

Cheers Kel

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2011-02-17
Last query:
2011-02-17
Last reply:
2011-02-16
Kel Fowler (f32dream) said : #2

Sorry that does not work, seems to want a different password.

OK, let's first see if you *are* an administrator. Open a Terminal window (Applications > Accessories > Terminal), and run this command (by pasting or typing it, then pressing enter):

groups

Then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

Also, please let us know whether or not you type a password in when you log on (i.e. in order to access your desktop and use your computer, after starting up your computer). If you type in a password to log on, then that means your password is what you think it is.

The two most common causes of this problem are (1) not being an administrator and (2) having forgotten (or never known) your password. Both are easy to fix, but we need to figure out which one it is (or if it's something else) first.

Kel Fowler (f32dream) said : #4

Hey Eliah

thanks for simple instructions.

this is the terminal view that you asked for '

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

oem@dell-desktop:~$ groups
oem adm dialout cdrom floppy audio dip video plugdev scanner lpadmin admin netdev powerdev
oem@dell-desktop:~$

' Yes I do sign in at the start, but I never used to, that only changed when I was trying to work out the admin password. so until I started screwing around with things there was no password at start-up. My start up password is not my admin password, I have tried it a million times.

Thanks again for your help.

Cheers Kel

"My start up password is not my admin password, I have tried it a million times."

That's very strange. Let's test this. Try running this command:

sudo echo test

Assuming you're prompted for your password, enter it. You won't see any placeholder characters (like *). That's OK. Just type it in and press enter. Then copy the text from the Terminal and paste it here.

Kel Fowler (f32dream) said : #6

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

oem@dell-desktop:~$ sudo echo test
[sudo] password for oem:
Sorry, try again.
[sudo] password for oem:

Sorry Dude, password did not work.

I installed Ubuntu from a CD that I had used years ago, I was unsure of linux then so deleted it, maybe I entered a password onto the CD back then and have forgotten it???

Cheers Kel

In Ubuntu, the password you enter to perform administrative tasks is the same password you enter to log in. It is possible to change this, but it is extremely unlikely that anyone would change it by accident. (To be clear--*changing* your password does not cause the "login password" and "admin password" to diverge, they are still the same even after you have changed your password.)

Just so I'm certain I understand: Are you saying that you have enabled a login screen, which comes up when you boot up your computer, and that you are able to select your name and enter a password, and this password *works* for logging in (but the same password does not work to perform administrative tasks)?

I can deal with either a "yes" or a "no" answer to that question, but the steps will be different. If the answer is yes, then you'll have to examine and possibly modify some configuration files (which will be slightly complicated by the fact that accessing it is an administrative action). If the answer is no, then we'll have to reset your password.

Kel Fowler (f32dream) said : #8

okay the answer is yes and no.

When the operating system starts, I get a Dell ( I think) page that asks only for a password, not a user name. Yes I log in with it and correct I can not use it for admin tasks.

I did try to reset the password, but before I do that I need an admin password, so could not do it.

Cheers

Ah, I see.

The password you're entering when you power on your computer is your BIOS password. It has nothing to do with Ubuntu. You are asked for it before booting occurs--for example, if you tried to boot from a non-Ubuntu live CD, you would still have to enter that password.

In contrast, I had thought you were talking about a login screen, where you would specify what user in the Ubuntu system you wish to log in as, and that user's password. (If Ubuntu is configured to automatically log you in, which appears to be the case, then you would never be presented with this screen, and thus the BIOS password, as described above, would be the only password you'd be asked for, in order to start using your computer after turning it on.)

So the solution to your problem is simply for you to reset your Ubuntu password to something you know. To do that, follow these instructions:
http://www.psychocats.net/ubuntu/resetpassword

If you have any problems doing that, or after you do it you're still not able to enter your (newly reset) password to perform administrative tasks, please post again.

Kel Fowler (f32dream) said : #10

Thanks for this, but the next problem is, it asks for a user name. I do not re-call ever entering a user name. So how do I find out what my user name is?

Best Manfred Hampl (m-hampl) said : #11

as seen in the answer above "[sudo] password for oem" the user name that you use is oem

Hence
passwd oem
will be the command to use.

Kel Fowler (f32dream) said : #12

Eliah, thanks for you non-geek English and patience, you were very very helpful.

Manfred thanks for slotting in the missing piece.

Ubuntu is now updating itself after me changing and entering the new password.

Thanks Guys

Cheers Kel

Kel Fowler (f32dream) said : #13

Thanks Manfred Hampl, that solved my question.