With "nomodeset" in grub still need video driver

Asked by ealthuis on 2019-01-05

With nomodeset added to grub, the display is slow, jerky and not very cooperative.
Switching work spaces by right clicking on a work space in the launch pad fails.
I also find some sudo commands won't work i.e sudo ./install.sh tells me no such command "./install.sh"
NFS server is not available even though partitions are shown in /export ( firewall problem??)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu seahorse Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2019-01-08
Last query:
2019-01-08
Last reply:
2019-01-08

What video chip are you using?
What release of Ubuntu?
Does the system have a make and model?

ealthuis (ealthuis) said : #2

Sorry to not answer your questions, as I could not get anywhere with what was available.

Instaed I installed 16.04 which worked for the day, next day (now) same thing happened but I got a chance to upgrade to Bionoc Beaver... did so and all's well on the Western front, display OK speed OK. I do not have unity, I know the problem I had probably was related to ubuntu-unity7 not handling the UEFI motherboard.

I installed ubuntu-unity7 on three other computers without any problems, but they were all quite old i.e 2011 and before.

Now I have another problem and I will start another thread, it is NFS and security related.

As to your questions I used ubuntu-unity7 18.04LTS, CPU is I5-4444, video chip integrated.. Motherboard Gigabyte GA-B85-HD3

If all is well then please mark as solved.

18.04 is supported 10 years unlike previous LTS releases which were supported 5 years

ealthuis (ealthuis) said : #4

Thanks actionparsnip, that solved my question.

Manfred Hampl (m-hampl) said : #5

"18.04 is supported 10 years"
This is only half the truth, see https://wiki.ubuntu.com/Releases

Standard support for Ubuntu 18.04 LTS will end in April 2023 (after 5 years).
There will be the possibility for Extended Security Maintenance, adding __paid__ support for five additional years (until April 2028).

Ahhh I see. Thanks for clarifying

ealthuis (ealthuis) said : #7

As a result of all these shananigans, I still have the problem of NFS not being accessible by other computers, I believe the problem is firewall related but I have not so far been able to resolve that.

A few years ago we had Firestarter which was a simple but effective GUI to set the firewall to allow messages passing between trusted systems.

I started this whole journey because I do not like the current version of Ubuntu Linux i.e Bionic Beaver, it is now just like Windows, which I did not like.

I have a Unity version (18.04LTS) running on three other computers, and those machines work just fine. It is the UEFI that unity tripped on.

I am grateful for the support both of you (actionparsnip and Manfred Hampl) have given me over the years.

Now it is time to put this one behind us and go on to other challenges.

NFS and how to get past the firewall(s).

Manfred Hampl (m-hampl) said : #8

I do not see any connection between UEFI, Unity and NFS. In my opinion they are completely independent of each other. So I assume: If you have problems with them, these have to be separate problems to be tackled individually.

ealthuis (ealthuis) said : #9

The reason I had to state UEFI and Unity did not get along was that ubuntu-unity7 pretty well failed from the getgo i.e the monitor problem, solved with removing "nomodeset" and also the NFS problem which worked just fine until I installed ubuntu-unity7. Now since reverting to Bionic Beaver, through an upgrade from 16.04LTS I still have no NFS capability.

I suspect firewall settings, but so far I have not found a solution. Two computers sitting right beside the "server" continue to show : Jan 9 07:09:15 seanix autonfs.sh[869]: Fileserver is down.
message repeated every 60 seconds.

I do have another question 677386 relating to that problem.