error message login keyring did not get unlocked

Asked by Leo Newburn on 2013-01-20

I am running Ubuntu Studio, 12.10, Quantal, 64 bit.

After turning on my pc and bootup, after a few minutes an error message pops up: "Enter password to unlock your login keyring. The loginkeyring did not get unlocked when you logged into your computer."

Then, after logging into that dialogue box, and tap "unlock", I am able to continue my computer activities normally. Is this a bug?

Here is a link to my screenshot of said event.....

Question information

English Edit question
Ubuntu seahorse Edit question
No assignee Edit question
Last query:
Last reply:
N1ck 7h0m4d4k15 (nicktux) said : #1

This is not a screenshot , this is a pdf document.

If you have enabled the autologin option , then you must either to disable it , or clear up the login keyring.

To clear up login keyring see here how


Just set a blank keyring password and it won't bother you

Leo Newburn (leokn) said : #3

I'm not sure what I did to "enable the autologin option"; I suspect I maybe did that during my OS install.

Thanks, NikTH and actionparsnip, for your quick and thorough responses! I am comfortable knowing that my error message experience here is not a bug. I'll try your suggestions and then report my results, then close this thread as "problem solved".

re: "This is not a screenshot , this is a pdf document.", I will study and learn how to make more acceptable screenshots; I don't quite understand why saving it in pdf format on Ubuntu One, as I did, is not correct protocol, but, as all my learning curve experiences with the Ubuntu world, I'm sure I will end up learning more!!

Cheers!! good work, my friends.

Leo Newburn (leokn) said : #4

I appreciate all your help.

re: "Just set a blank keyring password and it won't bother you", I don't understand your suggestion. When and how do I set a blank password?

re: "To clear up login keyring see here how", my desktop and menus are different than those described and pictured.

What I did: I took the information and used it to fix my problem as follows: ("<...>" means I opened the ... program within the brackets)

   <Settings Manager (Graphical Settings Manager for Xfce 4) >
   <Session at Startup>
   <Application Autostart>
  Then from a dropdown long list of stuff I don't really understand the meaning of, (some items already checked and some not), I checked the item (in italics) <Certificate and Key Storage (GNOME Keyring: PKCS#11 component>

The result: I rebooted and evidently so far my problem is gone.

I hope my information will be helpful to this website.

Cheers! ~Leo Newburn

Can you help with this problem?

Provide an answer of your own, or ask Leo Newburn for more information if necessary.

To post a message you must log in.