seahorse doesn't show passwords (xubuntu)

Asked by thomaz de gouveia on 2012-02-25

Linux thomazG51j 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

I installed seahorse to manage my passwords, but it just show the password “login”. My machine has stored passwords for e-mail, wifi, ssh connections, and they are working flawless. My problem is that I just can't find them.

When I start seahorse from terminal I get the follow error messengers:

** Message: init gpgme version 1.2.0
WARNING: couldn't connect to: /tmp/keyring-STVpHD/pkcs11: No such file or directory

** (seahorse:3517): WARNING **: Couldn't initialize registered PKCS#11 modules: An error occurred on the device

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu seahorse Edit question
Assignee:
No assignee Edit question
Solved by:
Andrea Corbellini
Solved:
2012-02-25
Last query:
2012-02-25
Last reply:
2012-02-25

Your password are stored inside "login". Just expand the item (double click on it or press the + sign). "login" just means that the password are unlocked at login, it doesn't contain the login password.
Please do ask if you need more help.

thomaz de gouveia (thomgou) said : #2

Nope,

There aren't nothing there :(
I unlock it, but it is empty. I set up my passwords without seahorse installed, can be it a issue?

Thanks

No, it's not an issue. Given that seahorse is installed by default in Ubuntu, I'm assuming that you are not using Unity/Gnome, but maybe Kubuntu (KDE), Xubuntu (XFCE) or something else. Seahorse looks for passwords in the Gnome keyring, so only applications that use the Gnome keyring will show up there. If you tell me the names of the applications you are using, then I'll be able to give you a more detailed answer.

thomaz de gouveia (thomgou) said : #4

No, i don't liked Unity or Gnome 3, they make a mess on my pc, so I changed to Xubuntu and it doesn't install seahorse by default, Xubuntu comes pretty clean.
I'm looking for my e-mail password used by Thunderbird , i forgot it :(.

Thunderbird (like Firefox) has its own keyring. To view saved passwords, you have to select Tools → Options... → Privacy → Passwords → View Saved Passwords.

WiFi passwords can be seen with the "Network Connections" tool (also known as nm-connection-editor). Open it, go to the Wireless tab, select the access point you are interested in, click Edit and go to the Wireless Security tab.

For ssh keys, there are no ways to access the password because the password is not stored anywhere. What is stored is the unwrapped secret key.

thomaz de gouveia (thomgou) said : #6

Thanks,
But as i remember seahorse stored those things at the old days, but i found what i need, very thanks

A little correction to Thunderbird, the path I found it is: edit > preferences > secutity > passwords > saved passwords.

thomaz de gouveia (thomgou) said : #7

Thanks Andrea Corbellini, that solved my question.