Unable to get prompt when stopping sddm in tty1

Asked by dodgyb

When switching to tty1 and running:

sudo service sddm stop

the screen reports 'Starting version 219'. Text input is displayed but there no command prompt. I am unable to switch back to tty7 though ctl+alt+delete reboots the system.

I am on Kubuntu 15.04, / 3.19.0-30-generic / Intel i915. A Nvidia 960 is on PCI 01 but no drivers installed.

I have tried editing /etc/default/grub specifying GRUB_CMDLINE_LINUX_DEFAULT="text" and GRUB_TERMINAL=console in various combinations. After update-grub and reboot the system hangs after detecting disks.

Finally I edited boot options at the grub menu with 'quiet splash' being replace by 'text' and '3' being placed at the end of the line. This results in a boot into sddm.

I need to stop sddm so I can install the nvidia drivers with necessary switches.

Any suggestions?


Question information

English Edit question
Ubuntu sddm Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

If you install the NVidia packages provided by the standard Ubuntu repositories, there is no need to stop the display manager before installing.

You could try selecting recovery mode from the grub menu (see https://wiki.ubuntu.com/RecoveryMode ) to boot in an command-line-only mode without sddm running

If you have a hybrid system with two graphic cards, you have to use additional software like bumblebee to allow switching between the two adapters.

Revision history for this message
dodgyb (dodgyb) said :

Thanks for your feedback Manfred

I should have mentioned that the Nividia will be used for compute only, bumblebee is not required. Unfortunately the CUDA version in the Ubuntu repo is two versions behind the current release, and also installs OpenGL which conflicts with the IGP libraries. This is why I need to build the driver from source.

Recovery mode has been attempted but my usb keyboard is unresponsive once the advanced menu is displayed. I suspect this may be due to how USB2 is converted to use the USB3 bus on Z170 chipset motherboards. The only option is a hard reboot once the advanced screen is displayed.

Can you provide insight into why the command prompt is not available on stopping sddm. Is this a known issue? My guess is it may be related to the Intel IGP.


Revision history for this message
Manfred Hampl (m-hampl) said :

I have no idea why your keyboard would refuse to work in recovery mode, or why the command to stop sddm does not succeed.

Other ideas:
stop the xserver with ctrl-alt-backspace (you have to enable this before, just google for it).
Instead of stopping the sddm process, try killing it

Revision history for this message
dodgyb (dodgyb) said :

I gave Kubuntu 15.10 a spin and stopping sddm works OK. I guess kernel 3.19 and maybe i915 graphics are not compatible with skylake hardware. Google only finds one forum mention of tty1 stuck at 'Starting version 219' after stopping sddm and that was on a skylake system too.

All I need to do now is persuade CUDA to build with an unsupported compiler on an unsupported kernel :)

Thanks for the tips.