Ubuntu

Intrepid screen resolution limited choices

Asked by BrianO on 2008-11-14

I have read many different posts and have found nothing that will work.
I am also a first time user of this sort of OS.
I tried the FAQ "How to get better screen resolution" and got the following error when I typed "sudo apt-get install displayconfig-gtk".
ERROR: Reading package lists... Done
Building dependency tree
Reading state information... Done
Package displayconfig-gtk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package displayconfig-gtk has no installation candidate

I can only select 2 resolutions, 800x600 & 640x480 and my monitor shows as unknown.
I have downloaded the monitor driver files from AOC's website and extracted them to a desktop folder.
This is a new installation of Intrepid on a PC that had only a newly formatted HD and no other OS on it.
Right now because of the resolution, I can not view some whole windows such as Transmission BitTorrent Client.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu screen-resolution-extra Edit question
Assignee:
No assignee Edit question
Solved by:
SapphirePaw
Solved:
2008-11-16
Last query:
2008-11-16
Last reply:
2008-11-16

To help you better we need some infos about your hardware so please open a Terminal from the menu Applications → Accessories → Terminal and type:

lsb_release -sd

and

lspci

lspci is lower of LSPCI

copy and paste result here.

Thank you

Then please also be sure your system is fully upgraded with no pending packages...

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(when the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove

Hope this helps

BrianO (orfordbf) said : #3

brian@brian-desktop:~$ lsb_release -sd
Ubuntu 8.10
brian@brian-desktop:~$ lspci
00:00.0 Host bridge: Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 (CGC) Chipset Graphics Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE Controller (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 02)
01:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
brian@brian-desktop:~$

BrianO (orfordbf) said : #4

Also complete the second set of recommendations with no changes to resolution choices.

thanks,
Brian

BrianO (orfordbf) said : #5

FYI, this is a Dell Optiplex GX110 PC

BrianO (orfordbf) said : #6

Just noticed another application that I cannot access all the functions due to the resolution and that is Evolution Mail. The "forward" button is not accessable to set-up the application.

BrianO (orfordbf) said : #7

Don't know how to contact someone, but I had originally had an I/O error during install that I could not find an answer on by searching. Just wanted to pass along that Nero express defaulted to "track-at-once" when burning the ISO and when I switched it to "disk-at-once", I was able to install without issue. Thought this may help with this issue but don't know where to post it.

Brian

BrianO (orfordbf) said : #8

7 PM EST before next contact.
Appreciate all responses in advance.

Brian

To get access to other (hidden because they are out of the screen) parameter or buttons on a low screen resolution you always do this:

Press and keep pressed the ALT keyboard key and click with mouse (and keep clicked) into a window area you want to move then drag it....

hope this helps

BrianO (orfordbf) said : #10

Thanks for that tip. Works OK. Any info on the resolution setting?

Brian

Any_Key (toddagreene) said : #11

 I experienced same problem after install. I had a 14" monitor connected. Solved problem when I connected a 17" Compaq 7500. Now I have more resolution choices than I need. I am using ATI 9550 with updated Linux driver.

Best SapphirePaw (sapphirepaw) said : #12

I have solved a similar problem - running Intrepid under virtualization (KVM+hardy host), the virtual monitor isn't auto-detected anymore. Xorg then falls back to a safe default, which supports up to 800x600 due to the default HSync range.

A minimal /etc/X11/xorg.conf can solve the problem. Here are the entire contents of my new xorg.conf (formerly an empty file):

  Section "Screen"
    Identifier "KVM Screen"
    Monitor "KVM Host Monitor"
  EndSection

  Section "Monitor"
    Identifier "KVM Host Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    # 'man xorg.conf' says you can set the pixel clock in KHz.
    # This is an UNTESTED example for 10-110 MHz clock:
    #Option "MinClock" "10000"
    #Option "MaxClock" "110000"
  EndSection

Replace the HorizSync and VertRefresh ranges with your monitor's actual capabilities. You can also use different identifier names if you want.

Under my new configuration, X starts at 1152x864, which seems to be the maximum 4:3 resolution that the emulated video card supports.

SapphirePaw (sapphirepaw) said : #13

One other thing: you can edit xorg.conf by going to Applications -> Accessories -> Terminal, then running the command 'gksudo gedit /etc/X11/xorg.conf'.

BrianO (orfordbf) said : #14

Many thanks to Any_Key, marcobra and most of all Chad Daelhousen who solved the issue with a simple edit. Worked like a charm using the exact setting that you gave. I now have a full set of resolutions and choice of 3 refresh rates.

Thanks again,
Brian

BrianO (orfordbf) said : #15

Thanks Chad Daelhousen, that solved my question.

jscanlan79 (jscanlan79) said : #16

Thank you so much Chad!! I have been pulling my hair out trying to figure out how to fix this. I'm seriously a beginner at this and your basic steps were completely helpful. I have been trying to fix this for weeks and just stumbled on your feedback. I could hug you right now! :-) Cheers!