Scapy3k conflicting with scapy: requires sorting out

Asked by Gabriel Potter on 2018-05-13

There are two scapy forks:
- secdev/scapy, the original fork, which only recently supports python 3 (since 2.4.0+)
- phaethon/scapy, a 2015 fork of secdev/scapy, which has been supporting for a long time, but has now diverged a lot from the original package (+ is outdated in many ways)

The second fork (phaethon/scapy) is wrongly packed as python3-scapy, whereas it has nowadays nothing to do with python2-scapy. This error was commited a long time ago, as the fork and its original had the same name, and is now very conflictiong.

On debian, the manager of those packets is renaming python3-scapy into python3-scapy3k, and making python3-scapy point to the same version as python2-scapy, knowingly secdev/scapy. The fork will now points to python3-scapy3k. This fixes all conflicts.

There are two options:
- perform the rename
- remove the phaethon/scapy and make python3-scapy points to secdev/scapy (no python3-scapy3k )

The real problem beeing that python3-scapy is not pointing to the correct fork (it should be pointing to the original one: secdev/scapy).

More infos: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=898105

EDIT: sorry, I am brand new to the launchpad system, sorry if this question notifies too many people / is in a wrong section

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu scapy3k Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2018-05-13
Last query:
2018-05-13
Last reply:
2018-05-13

I suggest you report a bug

Gabriel Potter (gpotter2) said : #2

Thanks actionparsnip, that solved my question.