Unable to use AGFA Snapscan 1212u with Xubuntu 16.04 & 16.10

Asked by Stéphane on 2017-02-19

Hi,

I recently installed xubuntu 16.04 from scratch and I wanted to install my old scanner AGFA snapscan 1212U. I followed the tutorial like this one http://doc.ubuntu-fr.org/scanner_agfa.

At the end, the command "lsusb |grepAGFA" recognize the scanner (Bus 004 Device 003: ID 06bd:2061 AGFA-Gevaert NV SnapScan 1212U (?))
The command "sane-find-scanner |grep AGFA" recognize the scanner too (found USB scanner (vendor=0x06bd [AGFA], product=0x2061 [ Snapscan1212u_2]) at libusb:004:003).

When I use one time the command "scanimage -L", the scanner is recognized too (found USB scanner (vendor=0x06bd [AGFA], product=0x2061 [ Snapscan1212u_2]) at libusb:004:003)

However, when I make a test like "scanimage >test.jpg", it doesn't work with an I/O error. After if I redo the command "scanimage -L" there is no scanner known (No scanners were identified)

After that, I tried to update to xubuntu 16.10 and the symptom still the same after the upgrade.

I created a live persistent xubuntu 15.04 with mkusb and performed the scanner installation and it works !!!

In this case, I supposed that there is a bug in Xubuntu16.04 & 16.10. I don't really want to downgrade and didn't find any support on the different forum and net.

Thanks in advance for your feedback.
Regards
Stéphane

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu sane-backends Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-20
Last reply:
2019-02-25
michael (yellupcm-gmail) said : #1

Stéphane
I have never used this, but take a look at these sites.

https://en.wikipedia.org/wiki/VueScan

https://www.hamrick.com/vuescan/agfa_snapscan_1212u.html

Hope this helps.

Stéphane (generique) said : #2

Hi Michael,

Thanks for your answer, however it isn't an issue with the driver. It works with Xubuntu 15.04 but it doesn't work with Xubuntu 16.04 or 16.10.

Regards
Stéphane

If you try:

sudo scanimage >test.jpg

Does it work OK? This tests for permission issues.

Stéphane (generique) said : #4

Hi Andrew,

Yes I tried it and it didn't work too.
Regards
Stéphane

Stéphane (generique) said : #7

Hi Andrew,

the package sane-snapscan.5.gz is provided by libsane-common_1.0.25+git20150528-1ubuntu2_all and I've already the latest library : libsane-common is already the newest version (1.0.25+git20150528-1ubuntu2)

I already tested the topic associated with https://ubuntuforums.org/showthread.php?t=2266355 and it didn't work.

Nicolas Granger (ngranger) said : #8

This is most likely related to https://alioth.debian.org/tracker/?func=detail&atid=410366&aid=315308&group_id=30186
This issue is solved in the development version of sane-backend (I have only tested on arch-linux).

gnc (gnc50) said : #13

however it isn't an issue with the driver. It works with Xubuntu 15.04 but it doesn't work with Xubuntu 16.04 or 16.10.

Regards https://xender.pro/ https://discord.software/ https://omegle.onl/

zim (zim220) said : #14

the package sane-snapscan.5.gz is provided by libsane-common_1.0.25+git20150528-1ubuntu2_all and I've already the latest library : libsane-common is already the newest version (1.0.25+git20150528-1 https://bluestacks.vip/ https://luckypatcher.pro/ https://kodi.software/

Can you help with this problem?

Provide an answer of your own, or ask Stéphane for more information if necessary.

To post a message you must log in.