Canoscan LIDE 70

Asked by Elbarbudo on 2010-06-21

There was a very old question about this scanner,
https://answers.launchpad.net/ubuntu/+source/sane-backends/+question/91948
and an old topic on SaneDevel forum.
I hoped the issue has been fixed, but even in Lucid Lynx, this scanner is not recognized.

Hence my comment : "Nothing new since 2006?"

I am very frustrated and disappointed, but I know that Canon does not share information.....

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu sane-backends Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-21
Last reply:
2020-05-14
David Mawdsley (dm-madmod) said : #1

I finally gave my Canoscan LIDE 70 away. I don't think Canon ever wanted to write a Linux driver for this scanner. My solution was to buy an HP Photosmart C6280 (or similar model) which has a flat-bed scanner as part of the unit. The scanner worked just fine with Applications > Graphics > Simple Scan.

Elbarbudo (patricearnal) said : #4

Worst story for this scanner : it is not recognized by W7 nor W10 : plugin it does not even emit the "bing" of a connected USB device.

My 2 cents idea is that the USB is off (or in a sleep state) on this scanner and that the XP driver awake it.

ios man (iosman002) said : #5

Yes. ScanGear MP v1.8 works directly and also through Gimp for my printer/scanner. I'm happy that libsane-pixma made it work with Xsane so I didn't have to switch to different software. Thanks

Can you help with this problem?

Provide an answer of your own, or ask Elbarbudo for more information if necessary.

To post a message you must log in.