Has the segfault bug in the epson2 driver been addressed in libsane?

Asked by Jack Klein on 2010-02-17

Please see Debian bug report #534746. This bug appears to exist in the current (1.0.20-4ubuntu3) libsane package. I am trying to use an Epson WorkForce 500 all-in-one scanner, and all attempts to query the device capabilities (e.g. scanimage -h, or initializing xsane or xscanimage) result in a segfault. The behavior is described in the above referenced Debian bug report, and is reported fixed in libsane 1.0.20-12.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sane-backends Edit question
Assignee:
No assignee Edit question
Solved by:
Gabe Gorelick
Solved:
2010-02-20
Last query:
2010-02-20
Last reply:
2010-02-17
Best Gabe Gorelick (gabegorelick) said : #1

It looks like Lucid currently has sane-backends 1.0.20-13, so it should be fixed there. Karmic only has 1.0.20-4, and it hasn't been patched in 18 weeks, way before the upstream fix was released, so I don't think it is fixed there. If it is that critical that this be fixed for Karmic, you may want to ask the package maintainers to get the specific fix backported.

Jack Klein (kleinjb) said : #2

Guess I'll just wait until Lucid is released then.