Mounting International characters

Asked by Gunnar Tryggvason on 2009-11-20

I mounted directory on my server disk, ext4-format, in the fstab-file.: //192.168.1.100/gagnadiskur /media/samba_share cifs credentials=/etc/samba/user,noexec 0 0. Icelandic characters are not recognised on this mount-pint, but when I go to the same directory threw Nautilus every thing is ok. Any suggestions how to fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
slc66
Solved:
2009-11-22
Last query:
2009-11-22
Last reply:
2009-11-22
slc66 (slc66) said : #1

Hi,

Use iocharset option.

Here is an exemple :
sudo mount -t cifs \
        -o iocharset=utf8,credentials=/etc/auto.smb.blackbox \
        //blackbox/myshare /mnt

Best slc66 (slc66) said : #2

Hi,

Use iocharset option.

Here is an exemple :
sudo mount -t cifs \
        -o iocharset=utf8,credentials=/etc/auto.smb.blackbox \
        //blackbox/myshare /mnt

Tanks. This solved my problem.