"Unable to mount location"

Asked by swornbrother on 2009-01-20

Hey guys, I can't get my Jaunty 64bit laptop to connect to my Intrepid 64bit (and vice-versa) laptop through samba. Every time I try, I get this error message:

"Unable to mount location

Failed to retrieve share list from server"

on the Jaunty laptop. It will however recognize that it's part of "WORKGROUP," but will not produce the machine name. I just gives that error message

The Intrepid laptop will actually show the machine name of the Jaunty laptop, but going into it, it's an empty folder.

I'm sharing files on both, so I know that's not the issue.

The fix mentioned in this thread:

https://answers.launchpad.net/ubuntu/+source/samba/+question/56781

did not work either. Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
swornbrother
Solved:
Last query:
Last reply:
Revision history for this message
j williams (nineowls+launchpad) said :
#1

This is not an answer to your question, but an alternative that works for me.
I mount remote systems using instructions here.
http://ubuntu.wordpress.com/2005/10/28/how-to-mount-a-remote-ssh-filesystem-using-sshfs/

Revision history for this message
PsYcHoK9 (psychok9) said :
#2

I'm very angry! I've this problem since 1 week and I've tried any trick without fix it.
If this problem isn't fix soon, I'm going to wipe Ubuntu & Co, I've spent too many hours without success! >:@

Revision history for this message
swornbrother (cwingler) said :
#3

Well, this isn't a fix to this specific problem, but I downloaded the KDE samba client (sudo apt-get install smb4k) and mounted samba shares through there until it's fixed.

Revision history for this message
PsYcHoK9 (psychok9) said :
#4

This can't be "Solved", your is a workaround... please open this bug, I want that is fixed soon... :(

Revision history for this message
TrocksFL (trocks4321) said :
#5

I am new to the world of Linux and wish I took the dive years ago. I have ubuntu 8.10 and cannot get it to work on my windows home network at all. I have 3 machines (XP laptop, Vista Desktop, and older HP box now running ubuntu 8.10) Network has been established for years and windows machines have no issues. ubuntu machine does see the network and connects. I can ping ubuntu from both windows machines and vice versa. I have spent "hours" (at least 15) reading up on how to fix this so I can "slightly" share in PsYcHoK9's anger :) I simply want to share windows folders with ubuntu and ubuntu with windows. Ubuntu (samba) shares do not appear on either PC and ubuntu Windows Network folder bring the same error message "Unable to mount location Failed to retrieve share list from server"

Revision history for this message
TrocksFL (trocks4321) said :
#6

Sorry, One other item: I am not a developer and did not understand what launchpad is (thought it was a support forum for ubuntu) so please let me know if it is not proper to host here? I found this site on google searching for an answer :)

Revision history for this message
mike hancock (javaiscoolmike) said :
#7

Are you using fire starter? if so, try see if it connects with fire starter disabled?

Revision history for this message
Twisted Lucidity (lucidlytwisted) said :
#8

This is *not* solved, all that has been shown is a workaround.

I have a VirtualBox image of 8.10 where Samba was working 100%. After upgrading to Jaunty it is hosed. It will not browse the network at all, although I can use "smb://<name>/" and "smb://<ip address>/" without any trouble. "smb://<workgroup>/" fails.

Windows works fine and can browse the network, including Samba shares, without issue.

I have run the tests with all firewalls off (even though 8.10 worked fine with them on) and fully re-installed Samba. No luck.

There is a discussion about this going on in the forums http://ubuntuforums.org/showthread.php?t=1134928 and a few people seem to be of the opinion that it is a bug in Jaunty. As a Linux newbie, I am not sure I can provide enough technical details to raise a bug.

Revision history for this message
phill.wall@gmail.com (phill-wall) said :
#9

I also have this problem and do not consider this solved.

I will use the work around but having to install extra software to work around that fact that supplied functionality fails - this shouldnt be set to solved till the problem is fixed.

Revision history for this message
v1nsai (v1nsai) said :
#10

I'm having this problem too, tried smb4k workaround but it's not seeing my windows workgroup on my Virtualbox guest at all, if I go to Places > Network I can at least see my workgroup, but get the error 'Failed to retrieve share list from server'.

I'm reading through the forum post phill posted now, but this is really starting to sound like an inherent bug in 9.04.

Revision history for this message
drdoormouse (drdoormouse) said :
#11

I think it has to do something with the recent updates...sometime earlier I was able toshare my files but now the same story....please some body help

Revision history for this message
drdoormouse (drdoormouse) said :
#12

I think it has to do something with the recent updates...sometime earlier I was able toshare my files but now the same story....please some body help

Revision history for this message
Peter Rhone (prhone-gmail) said :
#13

you have to edit the hosts line in /etc/nsswitch.conf to read:
hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

do this on each of the ubuntu computers involved, and restart samba.

for futher info see:
http://ubuntuforums.org/showthread.php?t=1169149

Revision history for this message
xq19space (tuxlux) said :
#14

Quote: you have to edit the hosts line in /etc/nsswitch.conf to read:
hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

Didn't work.

A final caveat; be careful regarding the advice on that thread. We ended up with some serious issues.

Revision history for this message
Will (moresouls) said :
#15

I have had the same problem with my computer however I found that after I created a normal share folder on my ubuntu computer, my windows xp computer could see it, and even take/save files in it. Unfortunately my ubuntu computer cannot see the xp computer. While it is kind of inconvenient to do it that way because you can't share printers I guess it is more better than not being able to share at all

Revision history for this message
Baditaflorin (baditaflorin) said :
#16

In Ubuntu 12.04 the same problem

Revision history for this message
SCCY (samuelcychan) said :
#17

I have been having similar problems from Ubuntu 10.04, to 10.10, 11.04, 11.10 and now 12.04. I feel REALLY inconvenient without having to browse shared files on a Windows-based LAN network.

At work, almost all computers in the LAN network are Windows (>90% Windows XP), and I am the only Ubuntu user in the network. Colleagues are exchanging files frequently through the Windows' shared folders almost everyday and I am the odd one out. I can't browse any Windows machine and files on the LAN network. I have to stupidly disturb my colleauges every time and beg them to copy those shared files on a USB flash drive just for me. I feel really embarrassed about this each time.

Would it be because my colleagues' machines are having non-ASCII (Chinese) names? For example, when I go to "Printing", trying to type a smb address on the printer-finding GUI text field, the text field just wouldn't let me type in any non-ASCII characters.

It makes me look stupid using Ubuntu, since file sharing is like a beginner feature for Windows users. My colleagues do not need to previously learn any file/printer-sharing knowledge and can figure out how to share things on Windows, while I have to install this and config that on my Ubuntu box, and, worst, no success in the end. Honestly, Samba has been really giving me nightmares since the switch from Windows to Ubuntu 10.04 years ago. This is the only barrier why I still can't persuade my friends and colleagues to switch to Ubuntu.