can not see network machines running 9.10

Asked by Bob Pearson on 2009-01-05

I have Ubuntu 8.04 running on 2 machines and Windows XP on a third machine. When I click 'Places', then 'Network' I can see all 3 machines on the MSHOME network, but when I click on the Windows machine I get nothing. Clicking on the other Ubuntu machine works fine. Also I can see all the shares on the Ubuntu machines from the Windows machine.

However if I click 'Places' then 'Connect to Server' and enter the full share name for the Windows computer 'XPmachine/shareddocs' then enter the password for the Windows machine and click 'Connect' the Windows shares appear mounted on the desktop and I then have full read/write access.

Connecting via Places > Network worked fine when we were using Ubuntu 7.10, the problem only seems to have occurred since we upgraded to 8.04.

I hope someone can help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
tmc1961 (tmc1961) said :
#1
Revision history for this message
Bob Pearson (admin-bpcsbromyard) said :
#2

I don't understand how that link helps. We have had Ubuntu on 2 machines for some time now and have not switched from Windows.

We simply have a problem on our Ubuntu machines reading from and writing to our Windows XP machine shared folders using Nautilus on Ubuntu Hardy 8.04, as I have already described. This problem did not occur under Edgy 6.10, Feisty 7.04, or Gutsy 7.10 as far as I can remember and certainly not on one of our Gutsy machines which I was using daily to transfer files backwards and forwards from the XP machine using Nautilus.

Now I can't do it completely via Nautilus, so what has happened? Is it a Nautilus problem, or a problem with Ubuntu Hardy, or some incompatibility between the two?

Answers would be greatly appreciated.

Revision history for this message
tmc1961 (tmc1961) said :
#3

Hey, I do know the frustration here. I have experienced it my self. I directed you to the web page because I was not aware of your networking abilities.
I choose to send noobies to the help section to get them to think.

This is not an Ubuntu; hardy; Intrepid issue.
I run a mixed; Windows/xp/vista, Ubuntu, Opensuse, Fedora core network. I do not have any share issues.

 I don't want to anger you but, can you tell me what has changed on your network that you can no longer share?
Is this an update to your OS or an addition of a new computer?

Are you sure you configured a FAT part.. for the window/linux share to work correctly?

Revision history for this message
Bob Pearson (admin-bpcsbromyard) said :
#4

Hi and thanks for your quick response.

The only thing that has changed is that we have updated our 2 Ubuntu machines from 7.10 to 8.04, nothing else has changed, I have even deliberately not run the latest SP3 updates on the Windows machine.

OK I am a newbie with regard to networking mixed Linux/Windows machines, but I am an old hand at diagnosing problems on industrial control systems and I know that if you do more than one thing at a time you can get confused, hence I deliberately only do one thing at a time.

The Windows machine doesn't have any FAT partitions just NTFS and the Ubuntu machines just have default partitions from the original 7.04 and7.10 installations and subsequent updates.

I really don't have a problem with the shares as I am used to using the command line, but my wife and my assistant hardware engineer are just used to stuff working over the GUI, so for them it is a problem.

I can add a fourth or fifth machine to the network using any Windows system 2000/XP/Vista via sockets on our workbench used for testing customer's machines and I can set up any of the Windows machines to see the Ubuntu machines and the other Windows machines no problems, but the Ubuntu machines will only see the Windows shares on the Ubuntu machines via Nautilus. In order to see the Windows shares I have to type in the share name of the Windows machine directly as I have already stated.

I had 2 Windows computers in today for repair, 1 x XP Pro and 1 x Vista HP and have saved data on the customers behalf to the third EXT3 drive on one of our Ubuntu machines which we keep specifically for that purpose, but I've had to push it from the Windows machine, I couldn't pull it from the Ubuntu machine, whereas previously under 7.10 I could pull it from the Windows machine to the Ubuntu machine.

No panic tmc1961, it's just an annoyance, but I would still like some kind of answer when you have time. best regards, Bob.

Revision history for this message
Bob Pearson (admin-bpcsbromyard) said :
#5

This morning I installed Ubunu 7.10 on a spare machine I had lying around, set up a shared folder on it and connected to my network. As expected I could access all the shares on all the other machines via 'Network' > 'Places' on this new machine and all the other machines could see the share on the new machine.

Then I upgraded the new machine from 7.10 to 8.04 using the update manager. Now the new machine has the same problem as the other 2 Ubuntu machines that I described yesterday i.e. they cannot see the shares on the Windows machine unless I type the share name directly via 'Connect to Server'.

There is obviously something in the upgrade which messes things up, but I am too new to Linux hazard a guess except might it be in the smb.conf file?

Do you think I should file a bug report?

Revision history for this message
Savvas Radevic (medigeek) said :
#6

Have you tried with Ubuntu Intrepid Ibex 8.10? Maybe it's already fixed in the newest release:
http://www.ubuntu.com/getubuntu/upgrading

Revision history for this message
Bob Pearson (admin-bpcsbromyard) said :
#7

I've upgraded the spare machine to Intrepid this morning and the problem is still there, so we now know that this affects both Hardy and Intrepid. When I get time I'll make a dump of the smb.conf file and then do a clean install of Gutsy again and check for differences.

Before I do that, however, are there any other files I need to check for differences?

Note that other people have reported this problem elsewhere on the Internet, check out the links...

http://fixunix.com/ubuntu/519572-ubuntu-8-04-cant-see-windows-network.html

http://www.computing.net/answers/linux/ubuntu-810-questions-review/30106.html

Revision history for this message
Savvas Radevic (medigeek) said :
#8

Try execute this command in terminal:
sudo apt-get install smbnetfs smbfs smbclient libsmbclient

Then restart your machine and try again. Otherwise, file a bug. seems you are right. :)

Revision history for this message
Bob Pearson (admin-bpcsbromyard) said :
#9

Hi Savvas,
Thanks for your suggestion which I have tried...
(sudo apt-get install smbnetfs smbfs smbclient libsmbclient)
but it hasn't fixed the problem.

I'll now file a bug report, but would still like to fix the problem, so if anyone can tell me where I should look in addition to the smb.conf file to try and diagnose this problem I would be very grateful.

Regards,

Bob.

Revision history for this message
EasTexSteve (saconroy) said :
#10

Hey Bob;

Did you resolve this problem? I'm having the same thing in 8.10. I can see the Ubuntu shares from Windows, but I can't see the windows shares from the Ubuntu machine. Unfortunately, your workaround isn't working for me. I can see the windows machines themselves, but it won't show me the shares on them.

Thanks,

Steve

Revision history for this message
Bob Pearson (admin-bpcsbromyard) said :
#11

Hi Steve,

No I haven't. I tried editing the samba.conf file to be as close to the 7.10 version as possible, but it didn't help. I'm no real expert, so I've left it the hands of those who are.

If you are using XP then I don't understand why the workaround isn't working, as it works on our two 8.04 and our one 8.10 machines with our XP Pro machine. I guess if you are using Vista then maybe it won't work.

Bob

Revision history for this message
EasTexSteve (saconroy) said :
#12

Thanks for the reply, Bob.
I got lucky a couple of times, and it did work. But, my success seems to be intermittent. I've tried it with both XP and Vista machines.with about the same rate of success. It's sporadic at best. I even got it to work once by putting the share name and the folder name in the appropriate boxes. As I said, it worked "once."

I guess I'll have to work on putting together a script file that uses the "mount" command.

Revision history for this message
David Perry (ubuntu-perrycs) said :
#13

The problem... I click.. places, Network, and it shows me all the networks... I chose PCS which holds all my computers and it never brings up a list after this. It just says...

Opening PCS...

Unable to mount location. Failed to retrieve share list from server.

This problem is far from fixed. I have a massive computer network at home (I run www.perrycomputerservices.com) my small business and I am pretty savy with computers.

If I use the old Ubuntu it works fine. When I upgrade to the new ones I can sometimes browse the network (intermittant) and the newest 3 Ubuntu's v8, v9 and now 10 never see my windows network ALTHOUGH all my windows machines can see the Ubuntu shares.

Some solutions I have tried that did NOT work...

* Boot off various versions of live dvd's (Ubuntu 8, 9, 10, Fedora, etc)
* Read thousands of articles on why it isnt working and changing files like smb.cnf or whatever its called
* Rearrange the order in config files to not freeze when shutting down when I finally get a share to work
* Installed various versions of Ubuntu on 2 different machines with the same results.
* Reset all equipment
* Replaced router with different one as a test
* Unplugged switches to allow a more direct connection to the "other" machines...

The ONLY solution I have found is this... and it took me forever to find it...

sudo mount -t cifs //gaming1/Enjoyment /mnt/gaming1share1

So simple but I dont know Linux. Only barely had time to scratch the surface.

Where gaming1 is the name of my machine and the sharename is Enjoyment. I created a folder under mnt called gaming1share1 and just used it there. You can stick the mount anywhere you like.

If I dont do that. It NEVER works. And since it's cross platform (Fedora, Ubuntu etc) I assume it's going to be messed up in all versions of Linux using whatever library was changed to break this.

What do I have for windows computers?

7 AMD Machines running Windows XP Home
2 AMD Machines running Windows XP Professional
1 AMD Machine running Windows Vista
2 AMD Machine running Windows 7 64bit
1 AMD Machine running Ubuntu 10.04 Release

The problems were happening before I had any Vista or 7 machines on the network. I can't even browse 1 machine if all others are turned off.

I have a 5? port gigabit router Dlink DIR 655, a 8 port Dlink Gigabit switch. a 8 port Linksys gigabit switch, 16 port Dell 10/100 switch, and a 8 port Dlink 10/100 switch. Total space 10,000 gigs approx.

Until this problem is fixed I cant take this OS seriously. A problem that's been lasting for months and months this serious and across multiple versions of the OS. The old ones are fine. Only since v8 has everything fell apart. And it's weird - but in V8 I was able to sometimes get in if I kept rebooting.

Hoping this problems gets fixed eventually. Ubuntu has a lot of promise.

I would allow someone to remote control my Ubuntu and try and find a solution to this. You can wipe out the machine if you like. I only use it to surf in the livingroom and watch youtube videos! lol. Its easy to reinstall.

Revision history for this message
czubek (michaelcharliedelta) said :
#14

I have the same problem and I am on Ubuntu 10.10. from WinXP I can see mu Ubuntu shares, but from Ubuntu I get as far as my workgroup and get a searching message followed by a failed to mount message.

Can you help with this problem?

Provide an answer of your own, or ask Bob Pearson for more information if necessary.

To post a message you must log in.