how do I network two llinux computers together?

Asked by crakken on 2008-12-28

I have two computers, a laptop with Kubuntu intrepid, and a desktop with Ubuntu intrepid, and dual booted xp. If I boot into xp my laptop finds all my shared folders through samba, but if I boot into Ubuntu I get nothing. I can connect the two through a remote desktop conection, and I can use the network manager to ping both of the computers, but no matter what I try, I can't share files between the two unless one of them is running xp. Can anyone help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
crakken
Solved:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1

Have you installed and configured samba server...?

https://answers.launchpad.net/ubuntu/+source/samba

Revision history for this message
crakken (mjasinski12000) said :
#2

I got samba installed on both computers. Now both of the computers show up under network places, but when I try to set the folders to share on my ubuntu system it tells me that I don't have the permission to change any settings. And when I try to change the settings on my Kubuntu system it tells me to enter my password, I do, then nothing happens. There is a button for configuring sharing but when I press it nothing happens. any suggestions?

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#3

Have you configured /etc/samba/smb.conf on both computer...

Here a section of my shared directory

[scaricati]
   comment = Scaricati
   writable = yes
   locking = no
   path = /home/danilo/scaricati
   public = yes
   browseable=yes

Thank you

Revision history for this message
crakken (mjasinski12000) said :
#4

what do they mean by" un-comment the following"? Is my home directory supposed to be in []. Am I supposed to be using gedit for this? Sorry kind of a noob.

Revision history for this message
crakken (mjasinski12000) said :
#5

ok got samba configured on both machines. The ubuntu machine is working great, but I can't configure any of my folders in kubuntu for sharing. If I press on the configure sharing button it asks me for my password. I put it in then nothing happens, and any subsequent presses of the button yield the same results minus having to put in my password. do you know if there is a terminal command to turn on sharing for individual folders? Or if there is a fix for this bug?

Revision history for this message
crakken (mjasinski12000) said :
#6

I got it working by adding the following line to the shared directory section

path = /home/mike

(mike is the name of the folder in the home directory)

now I can access all of the folders in my home directory.