Upgraded to Feisty and all my SAMBA shares no longer work.

Asked by Mark Thompson on 2007-04-22

I have just upgraded to Feisty with ease.

However, I share out data with the home network using Samba shares as we are a mixture MS and Ubuntu. We can no longer access data via the shares. I have tried deleting the shares and re-adding to no avail.

This seems to be consistent. I shared out a file on a Edgy machine and could get data via the share. I then upgraded this and could no longer access data via the share.

From the logs I notice.

Working shares have log entries of the form:
desktop2 (192.168.0.170) connect to service hda4 initially as user mark (uid=1000, gid=1000) (pid 4636)

and those that do not:
Desktop1 (192.168.0.188) connect to service hdd1 initially as user nobody (uid=65534, gid=65534) (pid 6760)

The entry for the share in /etc/samba/smb.conf looks soemthing like this

[hdd1]
path = /media/hdd1
available = yes
browsable = yes
public = yes
writable = yes

There is no entry for the share in /usr/share/samba/smb.conf has no entry for the share

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Thompson
Solved:
Last query:
Last reply:
Revision history for this message
debianmigrant (debianmigrant) said :
#1

Please try in a console:

testparm

this will test the syntax of the smb.conf

Revision history for this message
Mark Thompson (mark-r-thompson) said :
#2

Below is the output from testparm. Is all OK?

Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Processing section "[print$]"
Processing section "[hdd1]"
Processing section "[LARGE2]"
Processing section "[hda4]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        workgroup = THOMPSON
        server string = %h server (Samba, Ubuntu)
        obey pam restrictions = Yes
        passdb backend = tdbsam
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        panic action = /usr/share/samba/panic-action %d
        invalid users = root

[printers]
        comment = All Printers
        path = /tmp
        create mask = 0700
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers

[hdd1]
        path = /media/hdd1
        read only = No
        guest ok = Yes

[LARGE2]
        path = /media/hdd2
        read only = No
        guest ok = Yes

[hda4]
        path = /media/hda4
        read only = No
        guest ok = Yes

Revision history for this message
debianmigrant (debianmigrant) said :
#3

The syntax looks ok to me - and I'm not sure what your setup actually is but I would consider trying the following:

change in smb.conf (sudo gedit /etc/apt/sources.list)

;domain master = no

to

domain master = yes

If not try changing the domain logons to:

domain logons = yes

Also check your firewall settings and that all the shares have the same WORKGROUP

Hope it helps

Revision history for this message
debianmigrant (debianmigrant) said :
#4

Note you may have to run

sudo /etc/init.d/samba restart

each time you change the smb.conf so that your changes to effect

Revision history for this message
Mark Thompson (mark-r-thompson) said :
#5

I have tried the settings you suggested with just a little success. With the above setting change on of the shares me to see and apparent access the share, but no files appear. From the permissions dialog in Nautilus we get a message about "permissions could not be determined".

I have no firewall in this case to confuse the issue.. It is well with a private network

The smb.conf is vanilla apart from the share definitions and workgroup name.

Revision history for this message
debianmigrant (debianmigrant) said :
#6

Found this bug.. Looks like it could be related..

https://bugs.launchpad.net/ubuntu/+source/samba/+bug/48082

Revision history for this message
Mark Thompson (mark-r-thompson) said :
#7

Thanks for this, it has encouraged me to see if the problem exists on other upgraded PC's.

I have tried using samba as a test on other machines upgraded and it works fine. The others were vanilla installs of Edgy, so my problem is related to this one PC (which would have it I use as a file server). I will look into seeing if the bug mentioned is related tonight.

Thanks for the time and effort to help me.

Revision history for this message
Best Mark Thompson (mark-r-thompson) said :
#8

OK, from information in bug/48082 I checked to see if samba was running and it was not.
So tried.

1- sudo apt-get remove samba
2- sudo apt-get install samba
3- sudo /etc/init.d/samba restart

Still samba would not start even after a reboot.

so tried the following
1- sudo apt-get remove samba
2- sudo apt-get autoremove
3- sudo apt-get install samba
4- suso /etc/init.d/samba restart

Samba now work fine.

My apologies, forgot to record what was removed with autoremove properly, but some were related to apache.

In the aforementioned mentioned bug, the file of interest were /etc/rc3.d/K09samba and rm /etc/rc2.d/K09samba. These were not present on my computer. The following similar ones were:

/etc/rc0.d/K19samba
/etc/rc1.d/K19samba
/etc/rc2.d/20Ksamba
/etc/rc3.d/K20samba
/etc/rc4.d/K20samba
/etc/rc5.d/K19samba
/etc/rc6.d/K19samba

There were all are dates 7th Feb2007, 06:29:35

I do not know if this information is of use to anyone, but here it is anyway.

Revision history for this message
Benjamim (bbbenjy-gmail) said :
#9

See :https://wiki.ubuntu.com/Testing/EnableProposed,
My problem is solved

Benjamim A. Janeiro