Missing samba init.d startup script

Asked by jmandawg on 2008-11-23

I just did a aptitude full-upgrade tonight, and it broke samba. I had to completely purge it and reinstall. now it's mssing the rc*.d links and the startup init.d script.

how do i get the init.d script back?

Thanks in advance.

-J

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
jmandawg
Solved:
Last query:
Last reply:
Revision history for this message
jmandawg (jmandawg) said :
#1

It doesn't start the server or install the script.

root@webserver:/etc/init.d# apt-get install samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libcupsys2 samba-common
Suggested packages:
  cupsys-common openbsd-inetd inet-superserver smbldap-tools
The following NEW packages will be installed:
  libcupsys2 samba samba-common
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/7430kB of archives.
After this operation, 17.8MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Preconfiguring packages ...
Selecting previously deselected package libcupsys2.
(Reading database ... 29269 files and directories currently installed.)
Unpacking libcupsys2 (from .../libcupsys2_1.3.7-1ubuntu3.1_amd64.deb) ...
Selecting previously deselected package samba-common.
Unpacking samba-common (from .../samba-common_3.0.28a-1ubuntu4.7_amd64.deb) ...
Selecting previously deselected package samba.
Unpacking samba (from .../samba_3.0.28a-1ubuntu4.7_amd64.deb) ...
Setting up libcupsys2 (1.3.7-1ubuntu3.1) ...

Setting up samba-common (3.0.28a-1ubuntu4.7) ...

Creating config file /etc/samba/smb.conf with new version

Setting up samba (3.0.28a-1ubuntu4.7) ...
Generating /etc/default/samba...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
root@webserver:/etc/init.d# cd /etc/default/

Revision history for this message
jmandawg (jmandawg) said :
#2

Ubuntu Hardy 2.6.24-21-server x64

Revision history for this message
jmandawg (jmandawg) said :
#3

Nevermind, i did a

aptitude purge samba-common

and reinstalled and it worked.