How to connect Ubuntu 8.10 to a windows network share drive?

Asked by SRose

I have followed all the directions I could find (I have installed Samba, tried using the Windows XP machines IP address and its name, but all I get is a blank screen. Here is what I have tried:

* Places ->Connect to Server
* Change choice to Windows share and type in the IP address ( or the machine name (rcc-piii-tulian) in the server field => get a msg saying "Cannot display location "smb://rcc-piii-tulian/"

* Places -> Network
* See icon for Windows Network and double click it
* see icon for Workgroup (which is the name I kept for the home network) and I see the Windows machines on the network (ex. RCC-PIII-TULIAN)
* double click one of the Windows machines- get blank screen and the box at top reads "smb://rcc-piii-tulian/"
* even if I add "shareddocs" to the end (i.e.- the screen now reads "smb://rcc-piii-tulian/shareddocs") it still will not connect. (I get an error message saying "Could not display "smb://rcc-piii-tulian/shareddocs/". "Error: Failed to mount Windows share
Please select another viewer and try again."

The Windows machines are password protected and I do have to log in when connecting to the share drives from my other windows machines (although I have this now set on the Windows machines to automatically log on so I do not have to do it every time).

QUESTION: How do I get to these shareddocs folders on my Windows machines that are set for sharing and I can access them from all my Windows XP machines on my home network from my Ubuntu 8.10 computer?

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
d1bro (d1bro) said :


did you try that:

once i had similar things, as you describe - this solved it for me

Revision history for this message
SRose (s-m-rose) said :

Whoa- first off this is technobabel to me- sorry, but it has been over 35 years since I worked with UNIX, so to say I am rusty is beyond the truth. I have mastered Windows in all its incarnations and am willing to try Linux, but I have to say this is really daunting and frustrating.

Nonetheless, I have tried the instructions in the link and the very first step (typing "sudo mkdir /media/Steve" in the terminal window does not do what it should - no folder. on the desktop nor anywhere else I can find using Dolphin. OK, I then got to superuser priviledge and got to the etc folder, but once I get into etc (I use Dolphin), there is nothing named "stab."

So, lets start from scratch- as I said above,

I can see the windows machines using Network, but since the shared folders are password protected, when I double click on the machine, nothing comes up.

My Domain is WORKGROUP
My machine name is RCC-PIII-TULIAN
The shared folder is named SHAREDDOCS (but maybe it is c:\Documents and Settings\All Users\Documents)

I even tried the instructions from Iowa Dave using Server ( but nothing allows me to get to the password protected Shares on my windows machines. I get the following message:

"Cannot display location "smb://workgroup;Stephen%20Rose@rcc-piii-tulian/c:%5Cdocuments%20and%20settings%5Call%20users%5Cdocuments/Steve"

I admit I must be dense, but I am really at wits end here as I need to allow access to the windows shares so that we can share documents across all computers on the home network.

Thanks for any help I can get.
steve rose

Is there a way using the Network utility in 8.10 to get to these shares?

Revision history for this message
SRose (s-m-rose) said :

Actually, in playing some more I realized the issue is that each of the Windows XP Pro machines on my home network is password protected, not the share drives (folders) per se.

So, the issue is how to log onto a Windows XP computer from an Ubuntu box, not logging onto a specific folder.


Revision history for this message
SRose (s-m-rose) said :

One more piece of information:

I set up a shared folder on the Ubuntu box (/home/srose/Documents), enabled it as a share in samba, and can get to this folder from my Windows XP boxes.

I still can not get to the Windows folders on my Ubuntu box.


Revision history for this message
SRose (s-m-rose) said :

OK- many hours later and in reality not knowing what exactly solved the problem, I can get to all shared folders on the home network. If I had to guess, I edited the "nsswitch.conf" file to add "wins" to the "hosts" line but I can not guarantee that that did the trick. I also shut the machine down and restarted and I guess that could have been the answer as well.

I also have to say that the instructions under "MountWindowsSharesPermanently"
are not up to date for Ubuntu 8.1.0 as are a number of other instructions that refer to Network setup instructions.

Nonetheless, now that this issue is solved, onward to using what is an extremely fast machine and getting all the applications up and running I need.

Thanks to all the developers and people who put in time on this project- I feel like this is my "back to the past" project.

steve rose

Revision history for this message
stentor007 (wilentz) said :

I cannot get fusesmb and samba to work in 8.10 Xubuntu. They were working fine in 8.04LT? Can anyone give a suggestion as to what might work in configuring Samba and Fuse to allow me to have a view of the windows xp shared folders, all of which have the correct permissions and were not a problem under 8.04??????

I have set the workgroup name properly in smb.conf, and changed the timeout to 120 sec in fuse.conf. Otherwise have not tinkered with the conf files.

Revision history for this message
stentor007 (wilentz) said :

OK, this is a bug in the samba library for 8.10, and I have solved it by regressing to libsmbclient from 8.04 Hardy. This is done by adding the Hardy repository to one's software sites in System > Software sources, then under Third Party Software add or enable the hardy partner. Once that's done go to the Synaptic Package Manager and look for libsmbclient. You will find (if you have 8.10) that the version is 2:3.2.3-1. Click on the install box and then go up to Package (on the menu bar) and select force version and get version 3.0.28a-1ubuntu4.4. Hit Apply (it will uninstall an unneeded file (I think) called gvfs-backends) and then you'll have a working version. To make sure Update Manager doesn't keep trying to change you back to 8.10, go back in Synaptic Package Manager select the libsmbclient again, go to Package on the menu bar and select "Lock Version." Now you're done and fusesmb and samba should work as desired to allow Thunar or other browsing of allowed Windows network shares.

Revision history for this message
caribconsult (jeff-tcconsult) said :

STENTO007: I tried your suggestion but the message I got was the older version is out of date and no longer available, so when I go to 'force version' the one you suggested is not listed. Now what do I do? I'm having the same XP machines can see the Ubuntu shared resources but not vice-versa unless I login to Ubuntu as 'root' I'm thinking this has something to do with users rights, since 'root' can see the WinNet resources but other users can not, but I can't find anything to change that has opened up this access.

I'd sure be grateful for some help here.

Revision history for this message
PD Rhoades (mcdugal2) said :

My problem is I can view my windows shares just fine (I don't use user/passwords) I just can't figure out how to share folders from Ubuntu and view them from windows... also is the a gui way to make those windows folders i can view from Ubuntu permanent, instead of using the terminal?

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

@ PD Rhoades

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here:
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Thank you