Problems browsing windows shares following 8.10 upgrade

Asked by magicduncan on 2008-11-01

Hello there,

I have had Ubuntu installed on both my Laptop (a 2 1/2 yr old Sony Vaio) and a more recent desktop system that I have. Both were running Ubuntu 8.04, and I have upgraded each to 8.10. On my local network I have been running a Freecom network drive on my local network.

Previously, when running 8.04, I could view this network drive as a samba share by going to smb://192.168.0.6/PUBLIC (this being the share made available by default from this device). Unfortunately, I cannot seem to get to this share or anything on this device following upgrading to Ubuntu 8.10. The same applies to both my Ubuntu systems.

Does anyone have any ideas what is going on here? Or has anyone had similar experiences with such devices?

Thanks,
Rosco

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
iconoclastlm (danfearnley) said :
#1

Not an answer, but to share my own research so far:

I have the same problem, I've checked and smbclient can't access it on the command line either.

I get some indications that there is a problem in authentication on the command line. First I got an error "Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled ". So I added "client lanman auth = yes" to /etc/samba/smb.conf, to test if the problem was really a deprecated type of authorisation. No dice, I got this:

"Domain=[ȇ] OS=[] Server=[���]
tree connect failed: ERRSRV - ERRaccess (The requester does not have the necessary access rights within the specified context for the requested function. The context is defined by the TID or the UID.)"

I have also made sure that the Freecom Network Drive is at the most up-to-date firmware.

But it worked under 8.04!

Revision history for this message
^_Pepe_^ (jose-angel-fernandez-freire) said :
#2

Hi!

+1. Same as here. I have a CH3DNAS Conceptronic NAs disk with same problem, same error with same behavior after upgrading from 8.04.1 to 8.10.

I've googled for LANMAN problem, and I've found some smb.conf tips, but lines proposed

You will need to set 'client ntlmv2 auth = no', to re-enable the lanman
> support required for security=share.

are not included in smb.conf file...

Any help will be appreciated!!!

Regards,
^_Pepe_^

Can you help with this problem?

Provide an answer of your own, or ask magicduncan for more information if necessary.

To post a message you must log in.