Printer Sharing and Network printing Have stopped working, following maintenance on our router

Asked by tomdjbaptist on 2008-09-26

Following an expansion our out office network, My ability to access windows file shares and print on the network has stopped. The internet still works. I'm using 8.04.

Many thanks for any help!

No router settings have changed and i suspect it's something to do with the addition of opendns to our network?

I'm very new to Ubuntu!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1

To help you better we need some infos so please open a Terminal from the menu Applications->Accessories->Terminal and type:

ifconfig -a

copy and paste result here.

Thank you

Revision history for this message
tomdjbaptist (tom-ndcys) said :
#2

eth0 Link encap:Ethernet HWaddr 00:0a:e6:ad:01:8c
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:16 Base address:0xd400

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:1106 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1106 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:55300 (54.0 KB) TX bytes:55300 (54.0 KB)

wlan0 Link encap:Ethernet HWaddr 00:0e:2e:c8:28:56
          inet addr:192.168.1.14 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::20e:2eff:fec8:2856/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:24730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:28085357 (26.7 MB) TX bytes:3297645 (3.1 MB)

wmaster0 Link encap:UNSPEC HWaddr 00-0E-2E-C8-28-56-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Thankyou for your time.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#3

How are your lan connected... ?
Your active connection now seems the wireless connection not the wired connection.

wlan0 Link encap:Ethernet HWaddr 00:0e:2e:c8:28:56
          inet addr:192.168.1.14 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::20e:2eff:fec8:2856/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:24730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:28085357 (26.7 MB) TX bytes:3297645 (3.1 MB)

Thank you.

Revision history for this message
tomdjbaptist (tom-ndcys) said :
#4

the lan is a mixture between wired and wireless computers. I am connected to a wireless router via wireless, but the computer i am trying to access is attached via cable to the router. I used to be able to navigate the network, and i can still see the network, when i click on network drives but can't get further than seeing the name of the network, no computer show up and the printer cannot be found.

Thank you again

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#5

Please try to install this package...

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get install nmap

give your user password when requested, you don't see nothing when you type it, then press enter.

Then please do a network scan... from terminal type:

nmap -sP 192.168.1.0/24

Then to view active services:

sudo nmap -P0 192.168.1.0/24

give your user password if requested, you don't see nothing when you type it, then press enter.

Please report something here.

Thank you

Revision history for this message
tomdjbaptist (tom-ndcys) said :
#6

Starting Nmap 4.53 ( http://insecure.org ) at 2008-09-28 12:03 BST
Interesting ports on my.router (192.168.1.1):
Not shown: 1710 filtered ports
PORT STATE SERVICE
23/tcp open telnet
80/tcp open http
443/tcp open https
1723/tcp open pptp
MAC Address: 00:50:7F:DD:7A:C8 (DrayTek)

Interesting ports on 192.168.1.12:
Not shown: 1711 closed ports
PORT STATE SERVICE
135/tcp open msrpc
139/tcp open netbios-ssn
445/tcp open microsoft-ds
MAC Address: 00:0F:1F:52:C0:FE (WW Pcba Test)

All 1714 scanned ports on 192.168.1.14 are closed

Interesting ports on 192.168.1.21:
Not shown: 1709 closed ports
PORT STATE SERVICE
135/tcp open msrpc
139/tcp open netbios-ssn
445/tcp open microsoft-ds
1025/tcp open NFS-or-IIS
5000/tcp open UPnP
MAC Address: 00:01:80:2B:83:25 (AOpen)

Interesting ports on 192.168.1.253:
Not shown: 1713 closed ports
PORT STATE SERVICE
80/tcp open http
MAC Address: 00:30:0A:84:0A:3A (Aztech Systems)

Nmap done: 256 IP addresses (5 hosts up) scanned in 21.417 seconds

this is what comes up.

Thankyou again

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#7

If it exist, can you open and paste some content of your /etc/samba/smb.conf file...?

I'm interested to this row: "name resolve order = lmhosts wins bcast host"

Open a Terminal from the menu Applications->Accessories->Terminal and type:

gedit /etc/samba/smb.conf

Please copy only this line...

Thank you

Revision history for this message
tomdjbaptist (tom-ndcys) said :
#8

# What naming service and in what order should we use to resolve host names
# to IP addresses
; name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
; interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself. However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
; bind interfaces only = true

Hope this is the right bit! Thanks

Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :
#9

Seems someting like this https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/259978
....
The workaround works like a charm, and should be put into an upgrade/release.
I went to my /etc/samba/smb.conf file and uncommented and changed this line:

name resolve order = lmhosts host wins bcast
to
name resolve order = lmhosts wins bcast host

Please using terminal type:

sudo gedit /etc/samba/smb.conf

give your user password when requested, you don't see nothing when you type it, then press enter.

uncomment ( remove the initial ";" ) to your row:

; name resolve order = lmhosts host wins bcast

and change the row as below, type:

name resolve order = lmhosts wins bcast host

save and exit

Then restart samba.

sudo /etc/init.d/samba restart

And try

Hope this helps

Revision history for this message
tomdjbaptist (tom-ndcys) said :
#10

You are amazing thank you so much for your time and help works like a charm!

Tom