Samba 3.2.1 backports? for Windows 2008 AD support?

Asked by dx9s on 2008-08-26

It has come to my attention (and quite rudely from my Microsoft Zombie counterparts) that I need to upgrade to newer version of (3.2.1 as of writing) from 3.0.26a!!! Samba 3.2.0+ supposedly adds support for dealing with Windows 2008 Domain Controllers (DC).

Cause appears to be that Windows Server 2008 actually follows some RFC (aka a fix that is broken in previous Windows server releases -- and Server 2003 will be fixed in a service pack soon -- if not already) but breaks pre-Sambe 3.2 from being able to JOIN (and authenticate via spnego)... This is somewhat critical and surprised to not see others having complained (assuming this means others have not been forced to upgrade to Windows Server 2008).

I've created .deb's before but I am not that good at it. I would either appreciate assistance or request a back-port of 3.2.1 (or newer) to gutsy and hardy (only Intrepid has Samba 3.2.1 / 2:3.2.1-1ubuntu4)...

Thanks in advance!

--Doug

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was reopened

  • by dx9s
Revision history for this message
dx9s (dx9s) said :
#1

Well I am in the middle of compiling the source package as it came from the Intrepid node for 2:3.2.1-1ubuntu4 (of Samba).

Had to manually installed:

libtalloc1_1.2.0~git20080616-1_i386.deb libtalloc-dev_1.2.0~git20080616-1_i386.deb

and also install some other -devs that where already available via apt-get

It's still compiling as I am writing this so I dunno if it will work.

Revision history for this message
dx9s (dx9s) said :
#2

TADA!
2008-08-26 14:39 libpam-smbpass_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 libsmbclient_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 libsmbclient-dev_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 libtalloc1_1.2.0~git20080616-1_i386.deb
2008-08-26 14:39 libwbclient0_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 samba_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 samba-common_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 samba-dbg_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 samba-doc_3.2.1-1ubuntu5_all.deb
2008-08-26 14:39 samba-doc-pdf_3.2.1-1ubuntu5_all.deb
2008-08-26 14:39 samba-tools_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 smbclient_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 smbfs_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 swat_3.2.1-1ubuntu5_i386.deb
2008-08-26 14:39 winbind_3.2.1-1ubuntu5_i386.deb

(the order for installing is a little bit of an exercise in patients)

BUT I can now perform:

% net -S w2k3 testjoin -d 3
...
Join is OK
[2008/08/26 14:46:38, 2] utils/net.c:main(1172)
  return code = 0

-and-

% net -S w2k8 testjoin -d 3
...
Join is OK
[2008/08/26 14:46:38, 2] utils/net.c:main(1172)
  return code = 0

and futher

% getent passwd
[all local and domain accounts enumerated]

I think the problem is solved!

Now if I can figure out how to upload this .deb into my personal package space! (it is confusing)

Revision history for this message
dx9s (dx9s) said :
#3

Oppps .. I clicked that I answer it (which is true) .. but it doesn't answer the question which is when (if ever) is 3.2.x going to be backported... for those (like me) that are able to make .deb files (and I am new to making .deb's) -- this is not as much of a problem (I guess).

It still needs to be resolved as 3.0.x has entered "maintenance" mode on the "Samba" side of development (aka no more features added)... translation: "The fix which is available in Samba 3.2 for AD support off of Windows 2008 will not be back ported [most likely] into 3.0.x codebase" ... and if gutsy is never getting 3.2.x (or Hardy as well). then until Ubuntu 8.10 (Intrepid) will be the first Ubuntu to support Windows 2008 DC's

--Doug

Revision history for this message
Martin Meredith (mez) said :
#4

Can you help with this problem?

Provide an answer of your own, or ask dx9s for more information if necessary.

To post a message you must log in.