synaptic unable to install - broken dependency samba-common

Asked by ndbrown on 2008-08-19

Binary package hint: samba-common

When trying to install samba-common by the package manager, I get
'E: /var/cache/apt/archives/samba-common_3.0.28a-1ubuntu4.4_i386.deb: corrupted filesystem tarfile - corrupted package archive'

I can't add any more packages through the package manager until I fix the broken dependency caused by this.

I installed Hardy Heron 8.04, alt version, and have attached my sources.list (I don't know if this will help or not).

ProblemType: Package
Architecture: i386
Date: Tue Aug 19 19:18:12 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: corrupted filesystem tarfile - corrupted package archive
Package: samba-common 3.0.28a-1ubuntu4
PackageArchitecture: i386
SourcePackage: samba
Title: package samba-common 3.0.28a-1ubuntu4 failed to install/upgrade: corrupted filesystem tarfile - corrupted package archive
Uname: Linux 2.6.24-19-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier
Solved:
Last query:
Last reply:
Revision history for this message
ndbrown (brownn0-deactivatedaccount) said :
#1
Revision history for this message
Chuck Short (zulcss) said :
#2

Not a samba bug.

Thanks
chuck

Revision history for this message
Best Olivier (olivier-lacroix) said :
#3

Hi !

delete all the cached packages

sudo apt-get clean

and then fix the situation with

sudo apt-get install -f

Revision history for this message
ndbrown (brownn0-deactivatedaccount) said :
#4

The apt-get clean followed by install cleared up the dependencies. It looks like a cached package was used.

thanks for your help!