gshare works fine as guest but can not login with owner, admin or registered user

Asked by b_sprocket on 2014-10-23

So I'm happy with ubuntu 14 LTS desktop in my office. I've been using a system as a repository for some files in my home office with 1404LTS with Samba & gshare installed. Its been great, I can drop files to a share from any mac or PC and I have the nice deja dup backing up,.. love it,.. but until now I've just been using/connecting as guest and that was fine. Sooner or later you you need to place a few files that not everyone can see. I tried to connect as registered user/owner of the shared folder and behold,.. can not connect... FWIW, as a test, I created a new folder and turned all settings on as I normally do but turned off guest and other access. It should allow the owner to access. I tried this with both a folder from home/desktop & from one on an external thumb drive with the same result. I do get to the login prompt so I know it reaches the system/directory and ask or credentials so it seems to be a UID/pass issue b/c I get access denied (from windows). I liked the simplicity of just sharing under properties with gsahre, I don't think I want to go full bore of re-installed or a separate install of 14 server... am I missing something obvious.

help is appreciated, thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Last query:
2014-10-23
Last reply:
2014-10-23

You could use SFTP which is active when you install openssh-server. You will have the same access as the user you connect as.

b_sprocket (edward-capra) said : #2

Because it works nicely as guest under SMB, I'm not sure its worth changing the protocol of the connection and needing to install a different server package.

Can you help with this problem?

Provide an answer of your own, or ask b_sprocket for more information if necessary.

To post a message you must log in.