MS office files alone do not open from network in Samba share/kubuntu 14.04 LTS system

Asked by S.S.Mani

I am new to Linux-kubuntu 14.04 LTS. I successfully created a live USB for 12.04, installed it, used as a stand alone laptop for a fewdays and then updated to 14.04 LTS. Had some issues with default e mail and browser but after changing them and with few attempts everything started working-nicely.

I don't rememebr whether samba was preinstalled or not, as i have autoremoved many times and also reinstalled it.

The first peculiarity i have noticed is, even if I auto remove samba and almost all connected packages to my knowledge, I am still able to see sambashare under Dolphin.

Now, and also many times in between, I am able to see all windows computers in my laptop, but kubuntu laptop is not appearing in any other computer.

Not even once, I have been able to open MS office files though Libre office acts as if it is opening the clicked document, but then nothing more happens! However I have able to copy, paste the files into my computer and work on them! And also PDF, photos etc open with no issue!

During my many of the experimental times, it used to ask for a password, but even if enter my login password it used to ask again and again.

Though samba is shown not as installed under Muon discover, even now samba share appears under dolphin as above.

Though relavant or not here, i give the output of smbtree command here; Followed by testparm command:

Enter manihome's password:
        \\SERVICELAPTOP mani
                \\SERVICELAPTOP\C$ Default share
                \\SERVICELAPTOP\ADMIN$ Remote Admin
                \\SERVICELAPTOP\hpLaserJ hp LaserJet 1010
                \\SERVICELAPTOP\print$ Printer Drivers
                \\SERVICELAPTOP\D$ Default share
                \\SERVICELAPTOP\IPC$ Remote IPC
                \\SERVICELAPTOP\AutoHPLa Auto HP LaserJet 1020 on PROJECT1
                \\SERVICELAPTOP\My Documents
                \\SERVICELAPTOP\E$ Default share
                \\CLIMAOFFICE\IPC$ Remote IPC
                \\CLIMAOFFICE\E$ Default share
                \\CLIMAOFFICE\C$ Default share
                \\CLIMAOFFICE\ADMIN$ Remote Admin
                \\ACCOUNTS2\DATA1 (D)
                \\ACCOUNTS2\BACKUP (F)
                \\ACCOUNTS2\DATA2 (E)
                \\ACCOUNTS2\TVSMSP250STAR TVS MSP 250 Star
                \\ACCOUNTS2\print$ Printer Drivers
                \\ACCOUNTS2\IPC$ Remote IPC
                \\ACCOUNTS2\AutoHPLa Auto HP LaserJet 1020 on PROJECT1
                \\ACCOUNTS1\Y$ Default share
                \\ACCOUNTS1\Organizer 2013 Premium Edition
                \\ACCOUNTS1\IPC$ Remote IPC
                \\ACCOUNTS1\F$ Default share
                \\ACCOUNTS1\C$ Default share
                \\ACCOUNTS1\AOM DOCUMENTS
                \\ACCOUNTS1\ADMIN$ Remote Admin
                \\ACCOUNTS-2\Printer2 Microsoft Office Document Image Writer
                \\ACCOUNTS-2\Printer4 Fax Printer
                \\ACCOUNTS-2\Printer3 Network Printer
                \\ACCOUNTS-2\hpLaserJ hp LaserJet 1010
                \\ACCOUNTS-2\EPSONSty EPSON Stylus C45 Series
                \\ACCOUNTS-2\TVSMSP250STAR TVS MSP 250 Star
                \\ACCOUNTS-2\print$ Printer Drivers
                \\ACCOUNTS-2\IPC$ Remote IPC

And the output of testparm command is:

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[manihome]"
Loaded services file OK.
Press enter to see a dump of your service definitions

        workgroup = MSHOME
        server string = %h server (Samba, Kubuntu)
        server role = standalone server
        encrypt passwords = No
        map to guest = Bad User
        obey pam restrictions = Yes
        guest account = smbguest
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        username map = /etc/samba/smbusers
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb
        guest ok = Yes

        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        print ok = Yes
        browseable = No

        comment = Printer Drivers
        path = /var/lib/samba/printers
        valid users = root, smbguest
        read only = No

        comment = windows file sharing
        path = /home/manihome
        valid users = root, smbguest
        read only = No

What should I do, "To make it possible for me to work with files and folders in other computers and vice versa Please?"

I will very thankful if guidence is given to a BEGINNER level person like me, with complere command and procedures.

thank you.

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
S.S.Mani (airomatic) said :

I tried the advice by actionparsnip (andrew-woodhead666) said on 2011-02-28 under question number 147283.

I was able to give a password as suggested for smb.

But the was unable to change the last entries suggested.

it said permission is a problem.

I dont know what I did was a correct step or not, and also whather i made any mistakes it it or what!

Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you mount a Samba share to a folder in your OS manually, is it ok?

Revision history for this message
S.S.Mani (airomatic) said :

I am sorry, as a new person here I do not know whether ACTIONPARSNIP has given me a solution, or that is an additional question. If it is an answer, I must say I don't know, and I am just waiting for some guidance. I will be happy to know more about his posting. Under documents in Dolphin, I created a folder called For file sharing and set parameters for that thinking it will help. That did not. (As I do not have the laptop right now with me at home I will check and post properties of that file, if that information will help.) Thank you.

Revision history for this message
S.S.Mani (airomatic) said :

I have verified and reverified many times what Ryan turner has concluded. (

"The bouncing libre office icon disappering, is the last state to which this sharing works."

Though not useful, I found that by copying and pasting from other networked computers, i am able to work in MS office files in Kubuntu. Also I am able to paste to other systems.

The one issue still pending is, other windows xp, 7, 8, 8.1 computers are not even getting kubuntu in their network view though now all are in MSHOME! Any help please?

I have not understood whether "mounting" has got anything to do with this, as it is not clear what is mounting, how to do that and where to do that etc. Thanks.

Revision history for this message
S.S.Mani (airomatic) said :

Using "Nnautilus-in-kubuntu-instead-of-dolphin", will it solve this issue anyway?

I give below the contants of the link also here;

"Kubuntu comes with Dolphin as the default File Manage, however, for someone who is coming from Ubuntu Dolphin doesn’t cut it. The reason I switched from Ubuntu to Kubuntu was Unity. It was extremely counter-productive.

If I am running GIMP with more than 2 files its quite impossible to select the desired file. The global menu messes it up between applications and much more.

I think, I am done with Unity or Gnome 3, Kubuntu is the way to go. However, I always use a mix. I am used to Nautilus, the default File Manager of Gnome. It allows you to open windows in Tab. It also lets you do much more. So, I installed Nautilus in Kubuntu and set it as the default File Manager. If you are missing Nautilus on Kubuntu, here is how you can do it.

1. Open Synaptic Package Manager (or Kubuntu Software Manager) and install nautilus.
2. Now go to System Settings and click on default applications.

3. Now click on the File Manager and select “other: click Add…” and click on the browse button next to it.


4. Under the General Tab click on Add button
5. Now type “nautilus” in the windows and OK.

Use Nautilus In Kubuntu Instead Of Dolphin
6. You will see File Manger added along with Dolphin and Gwenview. Click on Edit and under the Third Tab Application, enter the name Nautilus –> OK
7 Apply –> OK. Again Apply –> OK
8. Now you will see Nautilus as the default File Manager.

Enjoy the best of both worlds."

Has any one tried it with success?


Revision history for this message
S.S.Mani (airomatic) said :

Success though Partially, but because of my limited knowledge with terms here still some directories are not working.

Smb4K did the magic

I installed Smb4K from muon discover. opened the same. Now it lists all networked computers with ip address etc. On clicking, some directories decalre themselves to be automatically mounted and open in Libreoffice. But some directories ask for user name pass word and nothing works there. Hope knowledgeble people are able to guide me further with FULL instructions.

Revision history for this message
S.S.Mani (airomatic) said :

 posted a few questions here and I got many sincere answers. Thanks for everyone.

However i was not able to solve my problem of accessing other network computers from mu Kubuntu and also my kubuntu was not showing in other computers.

I have now successfully uninstalled Kubuntu using OS uninstaller. I propose to reinstall directly 14.04 LTS unlike my earlier method of 12.04 and updating it, and hope to succeed.

However i want to record one peculiar(my observation) thing that happened during the last attempt.

While i was trying to uninstal, for once I "Tried Kubuntu".

During that time I was able to access all network computers!

However after uninstalling and reinstalling the same version of kubuntu in the same computer in the same network, I got into the same network issues as earlier! I wonder why?

The only difference, to my knowledge in my installation was, during installtion i had allowed the third paty installations as well as updates to be installed? Could that be the reason for this behaviour?



Revision history for this message
S.S.Mani (airomatic) said :

sudo sed -i 's/X-KDE-Protocols=/#X-KDE-Protocols=/' /usr/share/applications/libreoffice-*.desktop

(Question ref no is 252440)

Oh, thank you Manfred Hampl for the above solution!

It works now.

Now i am able to open MS office files using Network in dolphin file manager

thanks a lot once again.