Home Folder Browse Network Windows Network shows Unable to mount location after updates

Asked by BCW142

Home Folder Browse Network Windows Network shows Unable to mount location after updates. Ubuntu 12.04 LTS did updates this morning for new flashplayer update, but now on both of my 12.04 LTS machines (both updated) I don't see my Samba shares, they work fine under Windows XP Pro and other video players on my network. I just can't get to them via Ubuntu 12.04 LTS anymore.
Also is there a way to get off this fast track of screw ups rather than updates? I see a number of 'updates' weekly and over the last two months I'm still fighting the NVidia problem (doesn't work except with X11 defaulted) and samba (client side) is now not working. Can I get the flashplayer update without killing the otherwise working systems?
Rebooting is not the answer, I tried that on my other system when it first started Wednesday, it still doesn't work from Ubuntu, I had to use SFTP from Windows to copy files in instead of normal samba (Windows Network).
Just checked my one older Ubuntu 10.04 LTS and it's doing the same thing! What happened this week? All my Ubuntu systems won't see shares and everything else does!
As far as I know there are no firewalls setup on the Ubuntu, and Samba has mostly been working for the last 5 years (8.04 LTS, 10.04 LST, and now 12.04 LTS). I'm behind the standared hardware firewalls and using WEP so I don't use internal firewalls so my players will work (WDTVLive, XBMC and others).
The error message is 'Unable to mount location' 'Failed to retrieve share list from server', what server, which server, there are 8 'servers' on my network most of the time. I can say the Windows ones mostly work even now, just Ubuntu is out (3 of them).

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

If youbrun:


Do you see the shares?

Revision history for this message
BCW142 (bcw142) said :

bcw@bbc-server:~$ smbtree
Enter bcw's password:

So nothing. Is smbtree a normal Ubuntu command?
I just used Windows 8.1 to move the files to my Ubuntu Server, it worked just fine and I'm watching one from a player in my livingroom (where the Windows8.1/Ubuntu 12.04 LTS) is. It dual boots using and internal 1T drive and an External 1T with Linux. The default is Linux, I have to use F12 (boot menu) to get Windows8.1

Revision history for this message
BCW142 (bcw142) said :

Is there a way to back track what updates were installed in the last week? Maybe I could figure it out that way. Hmm even adding this comment has bugs: 'There is 1 error.' in a window with a red ball with minus sign in it as upper left corner! I wish pictures were an option like they use to be here, they don't seem to be anymore. It makes it hard to get the problems across without pictures.

Revision history for this message
BCW142 (bcw142) said :

The answer to my own question above is yes apt has a history:

cat /var/log/apt/history.log #of course you can more/less and view in anyway you want. zcat for compressed history stuff

My current history shows:
Start-Date: 2014-02-03 10:29:54
Commandline: apt-get dist-upgrade
Upgrade: nvidia-173-updates:i386 (173.14.37-0ubuntu0.0.1, 173.14.39-0ubuntu0.0.1), nvidia-173:i386 (173.14.35-0ubuntu0.2, 173.14.39-0ubuntu0.0.1), lightdm:i386 (1.2.3-0ubuntu2.3, 1.2.3-0ubuntu2.4), python-apt:i386(0.8.3ubuntu7.1, 0.8.3ubuntu7.2), jockey-common:i386 (0.9.7-0ubuntu7.11, 0.9.7-0ubuntu7.13), liblightdm-gobject-1-0:i386 (1.2.3-0ubuntu2.3, 1.2.3-0ubuntu2.4), dkms:i386 (,, jockey-gtk:i386 (0.9.7-0ubuntu7.11, 0.9.7-0ubuntu7.13), python-apt-common:i386 (0.8.3ubuntu7.1, 0.8.3ubuntu7.2)
End-Date: 2014-02-03 10:34:27

Start-Date: 2014-02-03 10:35:45
Commandline: apt-get autoremove
Remove: nvidia-settings-304-updates:i386 (331.20-0ubuntu0.0.1), linux-headers-3.2.0-54:i386 (3.2.0-54.82), linux-headers-3.2.0-54-generic:i386 (3.2.0-54.82)
End-Date: 2014-02-03 10:36:16

Start-Date: 2014-02-07 13:33:03
Commandline: apt-get dist-upgrade
Upgrade: libpurple0:i386 (2.10.3-0ubuntu1.3, 2.10.3-0ubuntu1.4), lmms:i386 (0.4.10-2ubuntu1, 0.4.10-2ubuntu1.1), gnome-bluetooth:i386 (3.2.2-0ubuntu5, 3.2.2-0ubuntu5.1), perl:i386 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), lmms-common:i386 (0.4.10-2ubuntu1, 0.4.10-2ubuntu1.1), perl-base:i386 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), libcurl3-gnutls:i386 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), libgnome-bluetooth8:i386 (3.2.2-0ubuntu5, 3.2.20ubuntu5.1), libcurl3:i386 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), flashplugin-installer:i386 (,, gir1.2-gnomebluetooth-1.0:i386 (3.2.2-0ubuntu5, 3.2.2-0ubuntu5.1), perl-modules:i386 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), libperl5.14:i386 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), libpurple-bin:i386 (2.10.3-0ubuntu1.3, 2.10.3-0ubuntu1.4), libcurl3-nss:i386 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7)
End-Date: 2014-02-07 13:37:47

Can any of you see something above that might affect Samba Shares from the nmbd? Windows can see the shares Ubuntu doesn't. I think smbd does the sharing and nmbd should do the client or viewer end (which isn't working).

Revision history for this message
BCW142 (bcw142) said :

OK, solved now. Had to take my network apart and put it back together, but most of the problem was my ISP, Fairpoint.net one of the worst in New England. They mess up my connection regularly, for some reason generally on Sundays! I don't know why, but it an take weeks to get it back right like this time. It started with the samba problem and finished with no connection at all with my DSL. Took them from last Sunday when I called them till this afternoon (Wednesday) to fix it, it's been mostly down the whole time. So the problems were due to noise from the DSL line into the house that was causing the Samba problems with my network, showing up first under Ubuntu then later inthe whole connection going down for days. Fairpoimt likely crossed some wires on Sunday that took me down for good, but had to have crossed others back last month that started the Samba problem. So all your Samba problems may not be in your side of the network, they can come from outside from bad ISPs.