I can't share folders or files among different users on one computer

Asked by Ted Uhlman on 2013-01-12

Using Ubuntu 12.04.
I'm a recent convert, and still don't understand a LOT about Ubuntu Linux, but my problem today is that I can't make folders or files shared by multiple users.
As the Administrator, in the Home section, I have tried to play with the folder sharing and permissions. I have a folder called Public, (with a person on the folder icon), and I made another folder called PublicMusic that has two arrows on it (red pointing right, and green pointing left), and a lot of music inside, which I want whoever is logged in to be able to listen to. When I log in as a different user, I expect to see these drives, but I can't.

When I used to use Windows, I never put stuff in "My Documents" unless I wanted nobody else to see it. I put all my music in a folder in C:\Music2012\ or whatever, and all users could access the files.

And while I'm at it, why can't the administrator create additional folders in the File System section?

Also, when I plug in my thumb drive, whoever I log in as next is the only person who can see it; I have to unplug it and plug it back in again as another user... If this is the same issue, help me out, but if it's another issue, then I can deal with that some other time.

I suppose this is pretty elementary, but I really don't know what to do about this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Warren Hill (warren-hill) said : #1

The default security model limits access to files and folders and only the "root" can change that. However you have root privileges when you need them if you are part of the sudo group. The first user created is by default other users need to be manually added.

If you need help on how to do this just ask

To get the additional priviledges for a command line program you prefix the command with "sudo" and for a graphical program press alt-F2 then in the box that opens type "gksudo" followed by the name of the command.

Specifically to make your music available to all press alt-f2 and enter

-----------------------------------------------------------------------------
gksudo nautilus
-----------------------------------------------------------------------------

Enter you password when requested

Be careful now as inside the file manager you are a super user so could mess up your system if for example you decide to delete something important. Normally the system would stop you but now you are in charge.

Find the folder you want to make public right click on it and select permissions.

There are 3 sets of permissions
owner, group and others
owner is the person who owns the file, usually but not always the creator
group is the group of people with set privileges
other is everyone else

Set the options you want here for each group. Apply to Enclosed Files then close.

When you close the file manager you will be a normal user again

There is no Administrator, your first OS is a user. It is a member of the 'sudo' group which allows it access to run sudo, gksudo and kdesu (in kde).

If you want a shared folder between users you can do something like this:

sudo mkdir /home/shared
sudo groupadd sharedgroup
sudo chown $USER:sharedgroup /home/shared
sudo chmod 774 /home/shared

Now there is a folder that your first user is the owner of and the members of the 'sharedgroup' group have access to to, al other users can read the data but not edit it. To give a user access to the folder, just add them to the group.

Ted Uhlman (uhlmantr) said : #3

Thanks actionparsnip, that solved my question.