"A password is needed to get access to the partition E of win2000". Which password? The password of ubuntu system does not fit.

Asked by Werner Röhrkasten on 2012-11-30

On my notebook is running ubuntu 12.04.1 alternatively to the main system windows xp. Via LAN/router I want to read and write on the partition E of a second notebook, which is operating under control of win2000 system. To start this system, only the username is required, no password. To open the partition I get the message „A password is needed to get access to the partition E of win2000“. Which password? The password of ubuntu system does not fit. To do the same under control of windows xp of the first notebook I have no problems to read and write on Partition E. Why this disadvantage of ubuntu?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
Last query:
Last reply:

You use the account of your user under Windows. You will need to set the share as accessible by the user as well as the data be accessed by the user too.

Werner Röhrkasten (wr-542955) said : #2

I am not sure wether I understood your answer.

 I want to use ubuntu 12.04.1, which runs on a first notebook, to read and write on a second notebook, which runs under win2000. I am clicking on „ search network“, I get “windows network“, opening it I get „HEIMNETZWERK“, the name of my LAN. Opening it I get „nb-win2000“, the name of the second notebook system. Opening it I get the partition E of the windows system. Now I want open this one, but I get a label „A password is needed to get access to the partition E of win2000“. Which password? Win2000 is not started with a password. The Partition E on the second notebook can not be opened.

In oposite the same procedure done with windows xp, which is the alternative system on the first notebook, I can open the partition E without problems.

Therefore my question: How can I do the simple procedure using ubuntu? What have I to set otherwise in ubuntu?

N1ck 7h0m4d4k15 (nicktux) said : #3

Have you installed the samba packets ?

Open a terminal (CTRL+ALT+T) and try this

sudo apt-get install samba samba-tools

Then restart your Ubuntu PC and try to connect again.

Thanks

Werner Röhrkasten (wr-542955) said : #4

Hello Nick,

tank you for reply. I did exactly what you proposed, gave the command in the terminal und restarted the notebook. But the reaction of "open Datenträger E", that is the partition (E:) of win2000, is

„A password is needed to get access to the partition E of win2000".

Always stands beneath Username: werner
                                           Domain: WORKGROUP
                                           Password: <empty>

Local experts said, username and password should be the same on Ubuntu and win2000. Win2000 has no password.
But that would be a restriction compaired with windows. Windows xp does not ask for username and password after through connecting to Partition (E:).

N1ck 7h0m4d4k15 (nicktux) said : #5

Well , according to my knowledge local experts have a point here. I have a Windows 7 + Ubuntu 12.04 network sharing and I can use my printer (Windows connected-Desktop) through my Laptop (Ubuntu 12.04) , but I have the same password and username at both Operating Systems. I don't know what would happen if I change the password or username in one of them.
The fact is that I don't use the password that Windows provided (share network) so I assume this is not needed.

I installed samba packets (as I suggested to you) and everything worked out of the box.
Now , probably something is missing here and possibly is the password for Windows 2000.

Restriction ? hmm, yes , but do not forget that are different operating systems . If is a restriction then , from which side ? (Ubuntu=open source free software , Windows=Closed source restricted and non free software)
Windows + Windows always have a good relationship = same company = same OS.

Now , as you installed samba , try to UN-share the folders (from Windows 2000) and the re-enable share folders under Wokrgroup (again from Windows 2000) and then test from Ubuntu to see if you can connect.

Thanks

Best N1ck 7h0m4d4k15 (nicktux) said : #6

If above not works , then try something else that possible will work.

Change the username to match each other Operating Systems . Windows 2000 username and Ubuntu username must be the same. (no password, only username).

Then open a terminal and write this

 sudo smbpasswd -a USERNAME

and leave it blank.

where USERNAME your actual Ubuntu username (it should be the same as Windows 2000).

Then go to Windows 2000 and disable and re-enable the shared folders.

Thanks

Werner Röhrkasten (wr-542955) said : #7

Thanks NikTh, that solved my question.

Werner Röhrkasten (wr-542955) said : #8

Hello Nick,

thank you for the answer and being patient with me.

When I said, the discussed point would be a restriction compaired with
windows, so is that only the meaning of one person, who is not the big
expert of ubuntu.

Normally I am working very well with ubuntu.

Thanks once more for your help.

Best regards,

Werner