Ubuntu Server Unable to config SAMBA for file sharing

Asked by uccio on 2012-09-01

I install Ubuntu Server and work correctly , but when I configure SAMBA for file shering I can not shere any file with the ather machine on the Home network which consist of a 2 Window 7 , Window XP and 2 Ubuntu 12.4 .
Once I get the File Sherin to work I hop to use this machine for backup on a RAID 1or 3;
Your hel will be most aprociated, this is the first time I install a Linux Server and I only been using Ubuntu desk machine for approximatly 18 month, i been very happywith it.
Thank you in advance.
Uccio

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:

If you run:

sudo nano /etc/samba/smb.conf

add the below lines (but change it for your shares and usernames):

[Downloads]
path = /home/andy/Downloads
comment = Andy's stuff
browsable = yes
read only = no
writable = yes
valid users = leanne andy
invalid users = root bin daemon nobody

Press CTRL+X, Press Y, Press ENTER and then run:

sudo smbpasswd -a andy

(again match the names you add in the smb.conf file), you will use this to authenticate with. Now if you run:

sudo service smbd stop; sudo service smbd start

And the share will be accessible. If you want to add another share, just add another entry in the smb.conf file and restart the service. You can also add more samba users and you can control whom has access to what. Easy stuff.

uccio (judith-uccio) said : #3

This work well , I very much approciated your answer and the quik response
Uccio

Samba is a simple creature, setting up a samba file server is super easy. If you also install openssh-server you can access the files securely using SFTP so you can configure your router to allow the traffic, you can access the files over the web from another network.