Problem connecting to Window shared printer under Ubuntu 12.04 Precise Pangolin

Asked by jrminter on 2012-04-19

I am trying to set up Ubuntu 12.04 to print to a windows shared printer.

I have Samba set up properly and can see the remote box with the printer:

jrminter 1: smbclient -L //fortress -U jrminter
Enter jrminter's password:
Domain=[FORTRESS] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

 Sharename Type Comment
 --------- ---- -------
 IPC$ IPC Remote IPC
 print$ Disk Printer Drivers
 data Disk
 jrminter Disk
 HP-P2055dn Printer HP LaserJet P2050 Series PCL6
 ADMIN$ Disk Remote Admin
 C$ Disk Default share
Domain=[FORTRESS] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

 Server Comment
 --------- -------

 Workgroup Master
 --------- -------

so it sees the shared printer (HP-P2055dn)...

When I start gnome-control-center to add the printer, it doses not see the network printer. I tried to search by address as

smb://fortress/HP-P2055dn and click the "search by address" button and gnome-control-center just hangs.

What am I doing wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
jrminter
Solved:
Last query:
Last reply:
jrminter (jrminter) said : #1

I figured it out. I was running in "Gnome Classic" mode (minimal) and I don't get the "URI:" prompt for a printer; evidently FirewallD is not running. When I run in "Ubuntu" (Unity) or as Xubuntu, I get the URI dialog and it works. I have been using the lighter weight desktops because compviz/Unity has an issue on one of my systems...