cifs filesystems won't mount after upgrade to 11.10

Asked by David Hager

Son's Dell Latitude D420 had 11.04 installed. Fstab mounting of two cifs systems from a D-Link 323 NAS worked well. Since upgrade to 11.10, they won't mount at all.

cifs related fstab lines:
// /home/erik/Music cifs credentials=/home/erik/.smbcredentials
// /home/erik/Pictures cifs credentials=/home/erik/.smbcredentials

Command line sudo mount -t attempts for both consistently result in this new error:
"mount error (2): no such file or directory"

(e.g.: sudo mount -t cifs // /home/erik/Pictures -o credentials=/home/erik/.smbcredentials)

Am able to browse the NAS, though, and son's computer is in same workgroup as the NAS.

Have tried a variety of added fstab parameters with no change of functioning, for better or for worse. Have tried renaming the .smbcredentials file with no success. (Owner=root; Group=erik; only root has rw)

Have tried reinstalling cifs-utils. Nope. Added netbios name to smb.conf below the workgroup name and installed winbind. Nope. No better, no worse.

Have spent several hours poking around on this through the Ubuntu Forums and via general Google search. No joy.

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jean Michault (jmt-2000) said :

same problem for me.
this works when booting on old kernel (2.6.38-11) but not with new kernel (

Revision history for this message
Josh J (thingster) said :

Running into this same issue.
Seems to be running into issues with length. I have the same NAS - DNS-323 here's what I did as a workaround.

I mounted up to the root of volume_1 and it worked.

So -> mount //

It's ugly and I had to reconfigure my apps with this configuration but it works for now until this is fixed.

Can you help with this problem?

Provide an answer of your own, or ask David Hager for more information if necessary.

To post a message you must log in.