Kubuntu 11.10 Samba Installation help

Asked by mebuntu on 2011-10-19

Hi, I'm having a nightmare installing Samba/Samba4. The installation is successful apart from the following error:

"ProvisioningError: guess_names: 'realm =' was not specified in supplied /etc/samba/smb.conf. Please remove the smb.conf file and let provision generate it"

I've tried to remove the smb.conf file but it still doesn't work. I have also purged and reinstalled Samba and Samba4 but that does not work either. What can I do?

Best enubuntu (mr.tennents) said : #1

It's a bug:
https://bugs.launchpad.net/ubuntu/+source/samba4/+bug/857394

I suggest you to talk about this problem to the bug.

mebuntu (salsa-temps) said : #2

Thanks Enrico "eNry" Carafa, that solved my question.

Iain Alexander (netean) said : #3

didn't solve it for me. What did solve it was removing reference to domain controller and adding line for security.

see my post on h ttps://bugs.launchpad.net/ubuntu/+source/samba4/+bug/857394 for copy of my initial smb.conf file that worked for me