Can't access samba home shares

Asked by Deep Kumar Halwai

Hi,

I have setup ubuntu as my samba server. It is a VM. I can access the shared folders and home shared folders if I set guest ok = yes under [homes]. However, when I want to login with a username/password authentication, I get an error saying I do not have access to the resources. If anybody can help, I will be grateful. Following is my samba config.

[global]
  workgroup = WORKGROUP
  server string = %h Samba Server
  netbios name = UBNTU
  security = user
[homes]
  comment = Home Directories
  browseable = yes
  writable = yes
  guest ok = yes
  read only = no
  create mask = 0760
  directory mask = 0760
[share]
      comment = Ubuntu File Server Share
      path = /srv/samba/share
      browsable = yes
      guest ok = yes
      read only = no
      create mask = 0755

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
Deep Kumar Halwai
Solved:
Last query:
Last reply:
Revision history for this message
Emre AYTAÇ (eaytac) said :
#1

Have you added the users to samba passwords file? For example the username is bob; first assign this user a samba password, then try to connect the share with this username and SAMBA password, not system password. Assigning this user a samba password;

smbpasswd -a bob

after that type your password twice, then try to connect your share. Hope this helps...

Revision history for this message
Emre AYTAÇ (eaytac) said :
#2

P.s. A user's system password and samba password may be different, it is your choice.

Revision history for this message
Deep Kumar Halwai (kumar981) said :
#3

Hi,

I have tried that. I created a unix user. Then I created a samba user and its password is the same as the password on windows client. It doesn't work irrespective of whether the passwords are the same or not. Firewall is disabled.
Just can't figure what is wrong.

Revision history for this message
Emre AYTAÇ (eaytac) said :
#4

It should work. You should try to execute testparm command and check if there any errors or not. And also please have a look at /var/log/samba directory. if there is a file like ip_number.log or log_ip_number, please open the file and check for error strings. If possible please share the log files with us (you may use http://paste.ubuntu.com/)

Also have you check the /srv/samba/share directory permission? Your samba user have permission to read the directory?

Revision history for this message
Deep Kumar Halwai (kumar981) said :
#5

Thanks. I found out the problem. It was the windows client. I had shared the home folders and another 'share' folder. Windows was not allowing me to make a second connection. Here are the links which discuss the same.

http://social.msdn.microsoft.com/Forums/eu/biztalkgeneral/thread/aeeb452d-0254-4bc2-a598-20f1f57ee8e0
http://support.microsoft.com/kb/938120

Thanks for guiding me through this.