smb.config set-up

Asked by Thomas Fjord Iversen

I am new to Ubuntu and Unix/Linux and would like to use my newly configured machine as file server for the Windows computers at my home (my wife's laptop (Windows Vista), my own laptop (Windows XP), and a desktop also running XP. Samba is installed and I have tried to configure the smb.config to be part of the existing workgroup at my home (VESTERGADE26), and I have created user accounts for my wife and myself on the Ubuntu machine.

workgroup = VESTERGADE26

security = user

But the Ubunto computer is not visible from the Windows machines. I am also not entirely shure on how to, and where, to create the shared directories on the Ubuntu.

I have read through the official Ubuntu Documentation about configuring a Samba File Server, and although I am not a complete newbee with computers, I just can't get it working.

Is there a default config file for Samba that I can start with?

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Also run:

sudo smbpasswd -a username

(match the username with your system usernames, and set the same password, this makes life simpler)

You can then run:

gksudo gedit /etc/samba/smb.conf

and add:

path = /home/andy/downloads
comment = Andy's stuff
browsable = yes
read only = no
writable = yes
valid users = leanne andy
invalid users = root bin daemon nobody

As you can see (This is one entry from my smb.conf), the share is called Downloads allowing my two smb users, andy and leanne access. If you copy this and change the share path and the usernames then save the new file. You can then run:

sudo service smbd stop;sudo service smbd start

And the new setting will be used, You can now authenticate as the smbuser you add using smbpasswd (make the OS remember the account and you won't be bothered for the account again).

Can you help with this problem?

Provide an answer of your own, or ask Thomas Fjord Iversen for more information if necessary.

To post a message you must log in.