no samba module in Ubuntu 10.10

Asked by tiktin

Sorry to be back so soon with another question. I recently installed Ubuntu 10.10 on one of my computers and I really like it but it wont show up on any of the other computers on my network and the reason seems to be that I cannot create shares. And the reason I cannot create shares is "/usr/bin/testparm line 43 <module> no module named samba". I looked in /lib/modules and there is indeed no module named samba there. I have computers running Ubuntu 9.04 and windows on my network and I can see them fine from the 10.10 computer but not the other way round. My network works fine with all the other computers so this problem is unique to 10.10. Kind of makes me long for the old days of freespire when connection was automatic. Any ideas on how I can fix this problem? Thanks.

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Do you have samba installed? I suggest you upgrade your Jaunty boxes as it is EOL and not supported in any way

Revision history for this message
tiktin (tiktin-fiberpipe) said :

Well, ok, we solved it but was so long and complicated a process I can only touch on the high spots here. We downloaded the samba package using synaptic. The main problem was the old Windows bugaboo of version conflict. This was on the latest version of Ubuntu and apparently Ubuntu, samba and apt got a little out of sync. We had to go through all the samba files and weed out those which were not compatible with one another and replace them with files that were compatible with the version of samba we were using. Once we did that we were able to create shares, but still could not see them across the network. The rest of the process involved tweaking the smb.conf file. The settings you need depend on your system and your network, so what worked for us may not work for you. Eventually we got the computer and the shares to show up on the network but could not open any of the folders because, although we had set the password, the system was not accepting it. After vainly trying to fix this we solved the problem simply by making all the folders public. Fortunately security is not an issue on our network. The best advice I can give anyone who is having this problem is to get a book on samba and be prepared to spend a long time fixing it.

Can you help with this problem?

Provide an answer of your own, or ask tiktin for more information if necessary.

To post a message you must log in.