Tryng to save edited smb.conf file to configure for Samba

Asked by Rodger Bell

Upon following instructions on How-to configure Samba, I can open the 'read only' smb.conf file found in etc/samba/smb.conf but cannot save it as a txt file. It keeps saying it doesn't exist. I need to be able to edit it to configure Samba for Windows client access. Is the issue that I cannot save a txt file where it says one does not exist or is the issue that I need to be logged in as 'root' ?....if so how do I do this ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#1

You need to run:
gksudo gedit /etc/samba/smb.conf

or if you are using server:
sudo nano /etc/samba/smb.conf

the file is owned by root so is not edittable by your user. You MUST restart the service to apply the new config, you should use:
sudo service smb stop; sudo service smb start

HTH

Revision history for this message
Rodger Bell (arlbee) said :
#2

Thanks actionparsnip, that solved my question.