have not learned command to run Samba

Asked by Joe Bissett on 2010-12-31

As a complete n00b, I am setting up a network with an XP machine. I had connection, but I restarted, and now I get nothing in Places / Network.

I remember that my guru told me about setting Samba to run at startup, but we didn't get to it before he left.

I simply need to be reminded of the command line entry to run Samba

Thanks in advance, Joe

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu samba Edit question
Assignee:
No assignee Edit question
Solved by:
Joe Bissett
Solved:
2010-12-31
Last query:
2010-12-31
Last reply:
2010-12-31

The word "network" doesn't automatically mean file sharing, so please keep you questions accurate. You could run a mail server on the Ubuntu system and it would use the same network, just access a different port.

On the Ubuntu system, you can share files in many ways, the easiest way is to run:

sudo apt-get install samba

You can now use nautilus to share folders.

Joe Bissett (jbissett) said : #2

Thanks for answering. All of what you are saying has been done, and I had the icons for the shared folders and machines showing on Places / Networks / MS Network.

When I did a restart, I lost it all. I "think" that I just need to run Samba and everything will return to normal.

I'm looking for a command line entry to cause Samba to run. It is not yet set up to start automatically when I start Ubuntu. That wil be added later today.

Joe

Andrew Hayzen (ahayzen) said : #3

Hi Joe

Here are the commands to start/stop and restart samba once it is installed.

/etc/init.d/samba start
/etc/init.d/samab stop
/etc/init.d/samba restart

Hope that helps

Andy

Joe Bissett (jbissett) said : #4

Thanks a lot. Samba is running. Now I can continue to track my other problems. Happy New Year.

Andrew Hayzen (ahayzen) said : #5

Hi Joe

Good to hear you got it working.

If Samba doesn't start after reboot then add the '/etc/init.d/samba start' to the startup commands.

System->Preferences->Startup Applications

Hope that helps.

Andy

Happy New Year

Joe Bissett (jbissett) said : #6

Hi Andrew,

I am too new to Ubuntu to really know, but I am running 10.10, and according to my guru, we learned yesterday that the "init.d" has been changed in 10.10 and no longer works. I forget what the new command is but it "may" just be /etc/samba start.

In any event, I appreciate your interest and hope this little note is of interest to you.

Joe