Unable to connect with windows-based home network

Asked by Alex Riggle

I need to use a printer that is attached to a print server running Windows XP. The other computers in the house are using XP; this new computer of mine is the only one running a Linux-based system (Ubuntu 10.04). When I try to find the printer using System/Administration/Printing/Add/Network Printer/Windows Printer Via Samba/Browse, I can see the workgroup, and when I click on the workgroup it shows the computers in the workgroup, but when I click on the one that's the print server, it thinks for a while and then gives up, showing no shares or printers. I have tried just typing in the computer and printername in the box (using the proper format), and that doesn't work. I have also tried a trick suggested online: using an http address and port 631, and that doesn't work. I asked over on Ubuntu Forums, and once these things didn't work, my new friends deserted me.

Can anybody here talk me through this? Thanks.

I'm a new Linux user; I've only had this new 'puter for 1-1/2 weeks. Please be gentle.

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

What is the make and model of the printer?
If you have any firewalling (WIndows comes with its own crappy firewall by default), have you configured it to allow the local traffic, can the other systems print ok?

Can you help with this problem?

Provide an answer of your own, or ask Alex Riggle for more information if necessary.

To post a message you must log in.