Samba or Ubuntu problem? netbios name not saving in smb.conf

Asked by jbowen7

So when I edit my smb.conf.master file and add "netbios name = server2" to the global section, and then run testparm -s smb.conf.master > smb.conf as root. this is what the global section of my "new" smb.conf file looks like after cat smb.conf:
netbios name = server2 does not show up!!!!??? I'm thinking samba doesn't like karmic.. Further more my other Karmic boxes on the same subnet can't browse samba shares, while the windows and mac boxes can.. HA... and yes my Karmic box smb.conf WINS server is pointing at server2.

Anyone have any idea??

 server string = server2
 interfaces =, eth0
 bind interfaces only = Yes
 security = SHARE
 map to guest = Bad User
 obey pam restrictions = Yes
 pam password change = Yes
 passwd program = /usr/bin/passwd %u
 passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
 unix password sync = Yes
 syslog = 0
 log file = /var/log/samba/log.%m
 max log size = 1000
 name resolve order = wins lmhosts bcast host
 socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
 dns proxy = No
 wins support = Yes
 usershare allow guests = Yes
 panic action = /usr/share/samba/panic-action %d
 hosts allow =,,
 hosts deny =

Question information

Revision history for this message
jbowen7 (jbowen7) said :

Also I just realized that "security = user" doesn't show up in smb.conf either after doing testparm -s smb.conf.master > smb.conf.

I'm moving this up to bug since this is happening on two seperate karmic servers of mine.

Also my karmic host can't access a private share on the server.

I've tried mounting through Nautilus, terminal ( using smbclient and mount ) neither work....

Seems like a bug to me.

Revision history for this message
jbowen7 (jbowen7) said :


Can you help with this problem?

Provide an answer of your own, or ask jbowen7 for more information if necessary.

To post a message you must log in.