How to make samba derefer symlinks?

Asked by Vsevolod Velichko

I'm using Debian sid with Samba 2:3.4.6~dfsg-1 on my server and Ubuntu 9.10 on the client.
On the server I set up the following config:
 server string = %h server
 obey pam restrictions = Yes
 pam password change = Yes
 passwd program = /usr/bin/passwd %u
 passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
 unix password sync = Yes
 syslog = 0
 log file = /var/log/samba/log.%m
 max log size = 1000
 load printers = No
 dns proxy = No
 usershare allow guests = Yes
 panic action = /usr/share/samba/panic-action %d
 wide links = Yes

 comment = Home Directories
 valid users = %S
 create mask = 0700
 directory mask = 0700
 browseable = No
 browsable = No

 comment = All Printers
 path = /var/spool/samba
 create mask = 0700
 printable = Yes
 browseable = No
 browsable = No

 comment = Printer Drivers
 path = /var/lib/samba/printers

Then I set up the usershare:
$ net usershare info video

In the Video folder I have some files and directories, which in fact are symlinks to the files and dirs in outside folder.
But when I try to browse Video share from my Ubuntu system, that symlinks are simply not displayed.
I tried to insert "follow symlinks = yes", "wide symlinks = yes" and "unix extensions = yes" (that config options were found in the Samba manual) in the global section of my config, but as you can see above, testparm produces no error, but don't show "follow symlinks" and "unix extensions" options in dump.
Also, I tried to browse the share from my smbnetfs mounpoint:
 $ ls -l /s/WORKGROUP/SERVER/video/
-rw-r--r-- 1 root root 735295488 2009-08-15 15:48 normal_file
d????????? ? ? ? ? ? symlinked_dir
-????????? ? ? ? ? ? symlinked_file

No need to say, that even from smbnetfs mountpoint that symlinks are unable to be copied.
How can I make samba to provide them for me?
Thanks in advance.

Question information

English Edit question
Ubuntu samba Edit question
No assignee Edit question
Solved by:
Vsevolod Velichko
Last query:
Last reply:
Revision history for this message
Vsevolod Velichko (torkvemada) said :

Sorry, problem has been solved by setting "unix extensions = no" :)